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Introducing TracerDAQ
TracerDAQ is a collection of four virtual instrument applications used to graphically display and store input data and 
generate output signals using Measurement Computing data acquisition hardware:

n Strip Chart - log and graph values acquired from analog inputs, digital inputs, temperature inputs, and counter inputs. 

n Oscilloscope - display values acquired from analog inputs 

n Function Generator - generate waveforms for analog outputs 

n Rate Generator - generate waveforms for counter outputs 

TracerDAQ provides many features that let you configure hardware, save measurement data and configuration information, 
and print displayed data. Refer to each application for specific features.

You can use TracerDAQ with Measurement Computing PCI Series, USB Series, WLS Series, and PC-CARD hardware. You 
can acquire and display data with TracerDAQ soon after you install your Measurement Computing DAQ hardware.

TracerDAQ vs TracerDAQ Pro

Two versions of TracerDAQ are available - TracerDAQ and TracerDAQ Pro.  

TracerDAQ Pro provides all of the features in TracerDAQ, plus additional options that are indicated in each topic. 

For a summary of the feature differences between the two versions, refer to the "Feature comparison between TracerDAQ
and TracerDAQ Pro" topic.

Using MCCDAQ hardware with TracerDAQ

Before starting TracerDAQ, you must configure your Measurement Computing data acquisition hardware with InstaCal. 
InstaCal stores all board-specific configuration information in a configuration file named CB.CFG. InstaCal creates and/or 
modifies this file when board configuration is added or updated. TracerDAQ reads the CB.CFG file to access the data 
acquisition board. Refer to the Quick Start Guide that was shipped with your Measurement Computing hardware for 
information about configuring your DAQ devices with InstaCal.

Running TracerDAQ 

Run TracerDAQ by selecting Programs ���� Measurement Computing ���� TracerDAQ ���� TracerDAQ from the Start 
menu. TracerDAQ is installed by default in the C:\Program Files\Measurement Computing\TracerDAQ directory.

When you launch TracerDAQ, the main TracerDAQ window opens. You run TracerDAQ's virtual applications from this 
window.

A description of the selected application appears on the window. Click the Run button to start the application selected.

n With TracerDAQ, you can run one instance of each application at a time.

n With TracerDAQ Pro, you can run multiple instances of each application at a time, as long as the applications use 
different Measurement Computing DAQ hardware.

Click on one of the links below for an overview of the features in each application.

n Strip Chart

n Oscilloscope

n Function Generator

n Rate Generator
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Each overview also provides a link to a Quick Start exercise you can perform that gets you up and running quickly with 
the application.

Note on measurement units: Measurements may display in a TracerDAQ application with the suffix m, u, or n. These 
units correspond to the following:
m = milli
u = micro
n = nano
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TracerDAQ® End User License Agreement
IMPORTANT - READ CAREFULLY 

This Measurement Computing Corporation End User License Agreement accompanies the TracerDAQ software product and 
related media, printed materials, and "on-line" or electronic documentation ("Software"). The term "Software" also shall 
include any upgrades, modified versions or updates of the Software licensed to you by Measurement Computing 
Corporation. After reading this Agreement, you will be asked to accept its terms and continue to install the Software or, if 
you do not wish to accept the Agreement, to decline its terms, in which case you may not install, use or copy the Software. 
By clicking on the "I accept the terms in the license agreement" button, installing, copying or otherwise using the Software, 
you agree to be bound by the terms of this Agreement. If you do not agree to the terms of this Agreement, click on the "I 
do not accept the terms in the license agreement" button and/or do not install the Software. You will be entitled to a full 
refund of the purchase price. 
The Software is owned by Measurement Computing Corporation. It is protected by copyright laws and international 
copyright treaties, as well as other intellectual property laws and treaties, including, without limitation patents and trade 
secrets. The Software is licensed, not sold. Upon acceptance of this Agreement, Measurement Computing Corporation 
grants to you a non- exclusive license to use the Software, provided that you agree to the following terms:  

1. Use. All title and copyrights in and to the Software are owned by Measurement Computing Corporation. Accordingly, 
you must treat the Software like any other copyrighted material, except that you may install and use one copy of the 
Software on a single computer, provided that you keep the original solely for back-up or archival purposes. Except as 
stated above, this Agreement does not grant you any intellectual property rights in the Software.

2. Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, 
decompile, disassemble, modify, translate or otherwise attempt to discover the source code of the Software.

3. Separation of Components. The Software is licensed as a single product. Its component parts may not be separated 
for use on more than one computer.

4. Rental. You may not rent, lease, or lend the Software.
5. Transfer. You may not transfer your license to another party.
6. Civil and professional communications. You agree to communicate with Measurement Computing Corporation and 

its employees in a civil and professional manner in all matters relating to the support or use of TracerDAQ. Use of 
abusive or profane language in written or oral communication will result in the cancellation of your license.

7. Export. You agree that the Software will not be shipped, transferred or exported into any country or used in any 
manner prohibited by the United States Export Administration Act or any other export laws, restrictions or regulations.

8. Disclaimer of Warranty. The Software is being delivered to you "AS IS" and Measurement Computing Corporation 
makes no warranty, express or implied, of any kind, including, without limitation, as to its use or performance. Good 
programming procedure dictates that any application program be thoroughly tested with non-critical data before being 
relied upon. The entire risk arising out of the use or performance of the Software remains with you.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MEASUREMENT COMPUTING CORPORATION AND ITS 
SUPPLIERS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU MAY OBTAIN BY USING THE 
SOFTWARE. MEASUREMENT COMPUTING CORPORATION AND ITS SUPPLIERS MAKE NO WARRANTIES, EXPRESS OR 
IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTIES AS TO NON-INFRINGEMENT OF THIRD PARTY 
RIGHTS, MERCHANTABILITY, OR FITNESS FOR ANY PARTICULAR PURPOSE.

9. Limitation of Remedies. Measurement Computing Corporation and its suppliers’ entire liability and your exclusive 
remedy shall be, at Measurement Computing Corporation's option, either (a) return of the price paid, if any, or (b) 
repair or replacement of the Software.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL MEASUREMENT COMPUTING 
CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, SPECIAL, INCIDENTAL, INDIRECT, PUNITIVE, OR 
CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS 
PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING 
OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE OR THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT 
SERVICES, EVEN IF MEASUREMENT COMPUTING CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.
Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or 
the exclusion of implied warranties or limitations on how long an implied warranty may last, so the above limitations 
may not apply to you.

10. Indemnification. You agree to use, build, create or develop only those program elements, including without limitation 
objects or controls, for which you have the necessary patent, copyright and other permissions, licenses, and/or 
clearances. You agree to hold harmless, indemnify and defend Measurement Computing Corporation, its officers, 
directors and employees, from and against any losses, damages, fines and expenses (including attorneys’ fees and 
costs) arising out of or relating to any claims or charges that you have used, built, created or developed any program 
elements in connection with the Software in violation of another party’s rights or in violation of any law. 

11. Termination. This Agreement shall automatically terminate upon failure by you to comply with its terms. Upon 
termination, you must destroy all copies of the Software.

12. Other. This Agreement shall constitute the complete and exclusive agreement between us. This Agreement shall be 
governed by the laws of the Commonwealth of Massachusetts, and you hereby consent to the exclusive jurisdiction of 
the state and federal courts sitting in the Commonwealth of Massachusetts. This Agreement may only be modified in a 
separate writing signed by an authorized officer of Measurement Computing Corporation. If any part of this Agreement 
is found void or unenforceable, it will not affect the validity of the other terms of the Agreement, which shall remain 
valid and enforceable.

YOUR ACCEPTANCE OF THE FOREGOING AGREEMENT WAS INDICATED DURING INSTALLATION.

Copyright© 2007 Measurement Computing Corporation, Norton, Massachusetts

TracerDAQ is a registered trademark of Measurement Computing Corporation.
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Platform requirements and recommendations

Required software

You can run TracerDAQ on a computer running one of the following operating systems and software.

n Microsoft® Windows 2000 (SP4), Windows XP (SP2), Windows Vista
 

n Microsoft .NET® Framework 2.0
 

n DirectX 9.0c

n Measurement Computing's InstaCal

The TracerDAQ installation automatically installs the Microsoft .NET® Framework 2.0 if this application is not already 
installed.

The TracerDAQ installation always installs DirectX 9.0c even if the software is already installed.

PC-CARD hardware is not supported under Windows Vista.

System requirements

n Video card with 16 MB of memory and Direct3D Acceleration (see the note below)

n Minimum screen resolution of 1024 x 768

n Computer with Pentium® 4 processor and 256 MB of RAM
 

n A Microsoft-compatible mouse

Note: To verify that Direct 3D is installed and enabled on your computer, do the following:

1. From the Start button, select Run and enter Dxdiag in the text box of the Run dialog.
2. Click OK. The DirectX Diagnostic Tool dialog opens.
3. Click on the Display tab.
4. Within the DirectX Features pane, verify that the Direct3D Acceleration status is Enabled.

If the status is Disabled, click the associated Enable button next to the status to enable this feature. 

If the status is Not Available, you will be unable to run TracerDAQ. Upgrade your video card to one that supports 
Direct3D Acceleration. 

Supported Measurement Computing data acquisition hardware

n PCI Series, USB Series, WLS Series, and PC-CARD devices 

n InstaCal's DEMO-BOARD, a software-based data acquisition board that simulates analog input and digital I/O operations.  

Specific hardware requirements for each virtual application are listed below:

Strip chart

n Analog inputs

n Digital inputs

n Temperature inputs

n Event counters

n PCI-CTR Series 

n USB-4300 Series 

n PCI-2500 Series and USB-2500 Series counters 

Oscilloscope

n Analog inputs

Function Generator

n Analog outputs

Rate Generator

n PCI-CTR Series 

n USB-4300 Series 

n PCI-2500 Series and USB-2500 Series timers 
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How to use this help file
This online help file uses the following conventions:

 

Convention Explanation

Blue underlined text Text popup or hyperlink. 
n Clicking on blue underlined text either links to another topic in the help file, or shows 

additional information in a text-only "popup" window. 

Green underlined text Drop-down text used to show images. 

n Click once on green text to show an image in a drop-down window. Click again to hide the 
drop down window. 
For example, "The DAQ Hardware Settings dialog opens."

TracerDAQ Pro information.

This icon appears in the Table of Contents with topics that provide information specific to 
TracerDAQ Pro.

Information that is applicable to either TracerDAQ or TracerDAQ Pro is indicated in each help 
topic. 
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Feature comparison between TracerDAQ and TracerDAQ Pro
Two versions of TracerDAQ are available - TracerDAQ and TracerDAQ Pro. 

With TracerDAQ, you can run one instance of each application at a time. With TracerDAQ Pro, you can run multiple 
instances of each application at a time, as long as the applications use different DAQ hardware resources.

The following tables summarize the features provided in TracerDAQ and TracerDAQ Pro for each virtual application.

Strip Chart

 

Oscilloscope

 

 

 

 

Feature TracerDAQ TracerDAQ Pro

Channel types supported Analog input, temperature input, 
digital input, event counter

Analog input, temperature input, digital 
input, event counter

Number of channels Up to 8 Up to 48

Number of lanes (individually 
scaleable)

2 8

Maximum sampling rate Maximum "continuous" acquisition 
rate of the device

Maximum "continuous"acquisition rate 
of the device

Maximum samples per channel 32,000 samples 1 million samples

Print/preview strip chart Yes Yes

Capture a strip chart image to the 
clipboard

No Yes

Save as a history file (*.sch) or 
text file (*.txt or *.csv)

Yes Yes

Open a history file (*.sch), binary 
file (*.bin), or ASCII text file (*.txt 
or *.csv)

Yes Yes

Save configurations Yes Yes

Alarm conditions No Yes

Strip Chart Measurements window No Yes

Enter annotations No Yes

Software triggering No Yes

Hardware triggering No Yes

Time-of-day triggering No Yes

Linear scaling No Yes

Feature TracerDAQ TracerDAQ Pro

Channel type supported Analog input Analog input

Number of channels Up to 2 Up to 4

Maximum sample rate Maximum "continuous" acquisition 
rate of the device

Maximum "continuous" acquisition rate 
of the device

Print/preview oscilloscope Yes Yes

Capture an oscilloscope image to 
the clipboard

No Yes

Auto trigger Yes Yes
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Function Generator

 

Rate Generator

   

  
 

 
 

   

 
  

  

  
 

 
 

   

   

 
 

  

   
   

  

   
   
 

  

   

   

   

   

   

   

        

   

   

   

   

  
 

 
 

   

 
 

  

   

Channel triggering (level and 
position)

Yes Yes

Horizontal markers Yes Yes

Vertical markers Yes Yes

Save configurations Yes Yes

Load configurations Yes Yes

Save as a history file (*.osh), or 
ASCII text file (*.txt or *.csv)

Yes Yes

Open a history file (*.osh) Yes Yes

Oscilloscope Measurements 
window

No Yes

Reference channel No Yes

Math channel No Yes

Feature TracerDAQ TracerDAQ Pro

Channel type supported Analog output Analog output

Number of channels 1 Up to 16

Maximum sample rate Based on the maximum "continuous" 
rate of the device (see "Introducing
the function generator" for full 
explanation)

Based on the maximum "continuous" 
rate of the device (see "Introducing the
function generator" for full explanation)

Waveform types Sine Sine, Square, Triangle, Flat, Pulse, 
Ramp, Random, and Arbitrary* 

* Generated from data stored in a .csv 
or .txt file.

Waveform preview Yes Yes

Amplitude Yes Yes

Frequency Yes Yes

DC offset Yes Yes

Duty cycle No Yes

Phase No Yes

Gate ratio No Yes

Rate multiplier No Yes

Sweep (linear and exponential) No Yes

Open .csv or .txt file (arbitrary 
waveform)

No Yes

Save configurations Yes Yes

Load configurations Yes Yes

Feature TracerDAQ TracerDAQ Pro
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Channel type supported Counter output Counter output

Counter types supported n 9513-based counters 

n Timer output counters (USB-2500 
and PCI-2500 Series devices) 

n 9513-based counters 

n Timer output counters (USB-2500 
and PCI-2500 Series devices) 

Number of channels 1 Up to 20

Pattern types supported Continuous pulse Continuous pulse

Save configurations Yes Yes

Load configurations Yes Yes
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Introducing the strip chart
TracerDAQ's strip chart is a virtual graphing and data logging application used to acquire data from Measurement 
Computing DAQ devices that support analog input, temperature input, digital input and/or counter inputs. The strip chart 
supports the maximum speed of Measurement Computing DAQ hardware.

With the strip chart, you can perform the following tasks:

n Plot up to 48 channels of data acquired from one or more Measurement Computing DAQ devices with TracerDAQ Pro. 

Plot up to eight channels of data acquired with TracerDAQ.

n Display specific measurement values for each channel (TracerDAQ Pro only)

n Trigger the acquisition using an internal software trigger, external hardware trigger, or a timed interval trigger 
(TracerDAQ Pro only).

n Set up alarm conditions for each channel (TracerDAQ Pro only).

n Scale channel data.

n Change the timebase to view more or less data on the plot.

n Add comments (annotations) to the display plot.

n Save data as a history file (.sch) or text file (.txt or .csv).

n Import and plot binary (.bin) and text data (.csv and .txt).

n Isolate specific data for analysis.

n Play back an acquisition.

n Store hardware configurations for future use.

n Customize the appearance of the strip chart.

Hotspots on the strip chart let you change settings while the strip chart is running. 

Strip chart dialogs feature tool tips that explain the function of each option. 

A status bar on the strip chart lets you know the operation status, when an option setting is invalid, or if an error condition 
occurs.

Data is plotted on the strip chart in individually scaleable lanes. TracerDAQ Pro supports eight lanes, and TracerDAQ 
supports two lanes. You can select the lane number where you want to plot data. Multiple channels can be plotted in each 
lane.

Two moveable data point markers let you view data at specific locations on the strip chart. The value of channel data at 
each marker position appears in a separate window.

Error conditions are automatically logged in the strip chart’s Annotation dialog. 

Strip chart quick start

For a quick, hands-on exercise that shows you how to acquire and display data using the strip chart, click on the Quick Start 
button below.

This quick start exercise shows you how to acquire and plot data from Measurement Computing's DEMO-BOARD virtual data 
acquisition hardware. No additional hardware is required.
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Overview of the strip chart environment
When you run the strip chart, the Strip Chart window, the Strip Chart Measurements window (TracerDAQ Pro only), and 
the Strip Chart Markers window open by default, as shown here:

n The Strip Chart window plots the acquired data. Hotspots let you configure data and display settings right on the window.

n The Strip Chart Measurements window shows specific measurement values for each channel configured to acquire data.

n The Strip Chart Markers window shows the values of channel data at each marker, and also the amplitude difference 
between the markers for each channel.

Components on the Strip Chart window

Components on the Strip Chart window are identified below. Place your cursor over a component name to display a brief 
description. 

An asterisk (*) after the name indicates that the component is also a hotspot. For more information about strip chart hotspots, 
go to the Hotspots on the strip chart topic.
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How the strip chart acquires data

The strip chart supports the maximum speed of Measurement Computing DAQ hardware. When acquiring data from hardware 
channels that support paced I/O, the strip chart uses a scan function to acquire the data. If the channels do not support paced 
I/O, then single-point I/O is used to acquire data on those channels.  

When a device includes channels that support both paced I/O and channels that do not, the single-point I/O channels use a 
"current value" that is updated as fast as possible through the single-point I/O function calls. The strip chart reads the current 
values on these channels for each data point it reads from the scan buffer used for the paced I/O channels. The strip chart may 
read the same "current value" from a channel multiple times before it is updated. In this way, all channels on the strip chart 
have the same number of data points in their plots.

The display update time varies from device to device, and may take longer than the acquisition time to acquire the data.

Concurrent scanning of analog, digital, and counter inputs

When acquiring data from hardware that supports concurrent scanning of analog, digital, and counter inputs, such as the USB-
2500 Series hardware, timing is based on hardware timed I/O, and is not system dependent.

When acquiring data from hardware that dos not support concurrent scanning, timing is based on single-point I/O using the 
system timer, and is system dependent.

Error handling

Under most error conditions, the strip chart pauses the acquisition, and displays an error message in the acquisition status bar 
and in a message box. Click here for an example.

There are a few error conditions in which the strip chart attempts to restart after it pauses the acquisition: 

n DATA_OVERRUN (Universal Library error code 29)

n NO_REMOTE_ACK (Universal Library error code 186)

n INPUT_TIMEOUT (Universal Library error code 187)

For these errors, the status bar displays the error condition, and indicates that the strip chart is waiting to restart.  

If the error condition is OPEN_THREMOCOUPLE (Universal Library error code 145), the strip chart indicates the error condition 
in the status bar, but does not pause the acquisition.

All error conditions are automatically logged in the strip chart’s Annotation dialog. For more information, go to the "Entering 
or viewing annotations on the strip chart" topic.
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Overview of the strip chart menu bar
The strip chart menu bar options are explained in the following table.

 

Menu item Explanation

File Includes options you can use to:
n save, open, and close strip chart history files (.sch) and text files (.csv or .txt)
n Open and plot binary files (*.bin)
n save or load a configuration file
n preview and print screen captures of strip chart data
n set up strip chart preference settings

Click on the following button for instructions on how to perform these tasks. 

Edit Includes options you can use to:
n configure Measurement Computing data acquisition hardware
n scale strip chart data
n set the timebase value
n set up strip chart channels, markers, and display settings
n clear data from the strip chart
n copy an image of the strip chart to the clipboard (TracerDAQ Pro only)
n set up trigger options (TracerDAQ Pro only)
n set up alarm options (TracerDAQ Pro only)

Most Edit menu items are disabled when the strip chart is running or paused. You cannot 
change hardware, channels or display settings during an acquisition.

Click on the following button for instructions on how to perform these tasks. 

View Includes options you can use to:
n show/hide the Strip Chart Markers window (displays marker values)
n show/hide the Strip Chart Measurements window (displays specific channel 

measurements)
n show/hide user-entered annotations on the strip chart display 

n enable/disable pop up tool tips on strip chart dialogs

Action Includes options you can use to:
n run, pause, or stop acquiring data
n start, pause, or stop playing back scan data (go to "Playing back scan data on the strip

chart" for instructions on playing back data.)  

Help Includes options you can use to:
n open the TracerDAQ online help file
n view TracerDAQ version and contact information
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Hotspots on the strip chart
The Strip Chart window has several hotspots. A hotspot is an interactive area on the strip chart that lets you change 
settings while the strip chart is running. All hotspots have corresponding dialogs that you access through the strip chart 
menu bar to perform the same action.

You can enable and disable hotspots using the Display Settings dialog (Display Settings option on the Edit menu). 
Hotspots are enabled when the "Enable hotspot" check box is checked.

The following hotspots are available on the strip chart.

 

Hotspot Explanation

DAQ controls RunRunRunRun: Starts acquiring data from the configured hardware devices. 

n Begins logging data to a file, if logging is enabled.
n Begins monitoring for trigger conditions, if a condition is specified (TracerDAQ Pro 

only).
n This hotspot is disabled while the strip chart is running, and enabled when the 

Pause or Stop hotspots are clicked.

PausePausePausePause: Pauses data acquisition. The strip chart continues acquiring data, but the 
data is not plotted on the display. 

n Suspends data logging, if logging is enabled.
n This hotspot is disabled when acquisition is paused, and enabled when the Start 

hotspot is clicked again.

StopStopStopStop: Stops data acquisition and display.

n Stops data logging, if logging is enabled.
n This hotspot is disabled when the strip chart is stopped, and enabled when the 

strip chart is running or paused.

PLYPLYPLYPLY : Toggles playback mode on and off. 

SETSETSETSET : Opens a dialog for setting display, channel, and marker properties. 

Sets the value per major horizontal division. There are ten major horizontal 
divisions. Click the up/down arrows to change the value.

n You can set the timebase to 1µS, 2µS, 5µS, 10µS, 20µS, 50µS, 100µS, 200µS, 
500µS, 1mS, 2mS, 5mS, 10ms, 20mS, 50mS, 100mS, 200mS, 500ms, 1s, 2s, 5s, 
10s, 20s, 50s, 100s, 200s, 500s, 1000s, 1hr, 2hr, 5hr, 10hr, 20hr, 1day, 2 days, 5 
days, 10 days, 20 days, 50 days, or 100 days.

n If your computer mouse has a wheel, you can roll forward to increase the 
timebase value, and roll backward to decrease the timebase.

n Hold down the Shift key to change the timebase setting in multiples of 10. For 
example, when you change the timebase while holding down the Shift key, the 
value changes from 1.00s to 10.0s, 100s, 1000s, etc.

Auto mode:

n The timebase may also be set to AutoAutoAutoAuto mode by clicking on the AAAA   hotspot next to 
the up/down arrows. When enabled, the timebase value setting automatically 
increases when the strip chart acquires enough data to fill 50% of the screen for 
the next timebase setting scale. This is done in order to display all data points.

For more information on timebase controls, go to the Using strip chart timebase
controls topic.

Scale mode

 

 Fixed

 

  Auto

 

  NonOverlapped

 

Sets the scale mode for that lane. There are three scaling modes: Fixed, Auto and 
NonOverlapped. Clicking on the Scale Mode hotspot sequences through each mode.
n FixedFixedFixedFixed: The strip chart scales the data to the Upper and Lower limits set for the 

lane. In this mode, you can edit the range limits - click on the Upper Limit 
hotspot and Lower Limit hotspot to display a text box, and enter a new value.

n AutoAutoAutoAuto: The strip chart calculates a scale that best fits the data. In this mode, the 
Upper and Lower Limits are not editable.

n NonOverlappedNonOverlappedNonOverlappedNonOverlapped: The strip chart evenly scales all channels in a particular lane in 
magnitude and spacing so they do not overlap. In this mode, the upper and lower 
limits are not displayed. This mode is particularly useful for displaying digital 
inputs in the same lane.
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Playback controls Playback StartPlayback StartPlayback StartPlayback Start: Starts playing back data that has just been acquired or loaded 
from a previously saved file.

n When data acquisition has just been completed or a history file has been loaded, 
this is considered “playback” mode. 

n This hotspot is disabled while the strip chart is playing back data.

Playback PausePlayback PausePlayback PausePlayback Pause: Pauses playback of data.

n This hotspot is disabled while data playback is paused.

Playback StopPlayback StopPlayback StopPlayback Stop: Stops playing back data.
n This hotspot is disabled when data playback is stopped.

 (Playback speed) Increments or decrements the speed at which data is played back. Click on the plus 
or minus button to multiply the original data rate by the following values:
0.001, 0.01, 0.1, 1.0, 10, 100, 1000

n Click "+" to increment the speed, or "-" to decrement the playback speed. 

Playback scroll bar

Scrolls the data in playback mode toward the beginning or end of the acquisition.

n Scrolling left moves the data plot towards the start of the acquisition.
n Scrolling right moves the data plot towards the end of the scan.

You can also scroll data with the left and right arrow keys on the computer:

n Pressing the left arrow key moves data plot towards the start of the acquisition.
n Pressing the right arrow key moves data plot towards the end of the scan.

Tip: Hold down the Shift key while pressing the arrow key to increase the 
scrolling speed.

Acquisition progress bar: When the strip chart is not in playback mode, this scroll 
bar shows the progress of the current scan.

Markers The strip chart has two moveable markers used to view data at specific locations on 
the strip chart.

Scroll the markers from left to right to show the value of the data point at each 
marker's position in the upper left corner of the strip chart. 

The delta position (the time between the two markers) shows next to the Timebase 
hotspot controls in the upper right corner of the strip chart.

Marker values also appear in the Strip Chart Markers window, if visible. You can 
turn this window on and off with the View > Marker Values menu.

EEEE  (Edit mode) The EEEE  edit hotspot appears on the strip chart when you open a history (*.sch) file. 
Click on the EEEE  hotspot to toggle between ReviewOnly mode and Edit&Save mode. 

n Review Only mode: changes to the history file cannot be saved. The File > Save 
option is disabled. You can save changes to a different file name using the File > 
Save As option. This mode appears on the strip chart as: 

n Edit&Save mode: changes to the history file are automatically saved. This mode 
appears on the strip chart as:
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Quick Start - Plotting DEMO-BOARD signals with the strip chart 
As stated in the introduction, you can acquire and display data with TracerDAQ "soon after you install your Measurement 
Computing DAQ hardware."

You can get a feel for what TracerDAQ can do even sooner by trying it out with the DEMO-BOARD, which is a simulated ISA 
board included with InstaCal.

To acquire and plot DEMO-BOARD signals on the strip chart:
1. Make sure you have completed the steps in the "Running InstaCal and adding your hardware" section of the DAQ 

Software Quick Start.
2. Run TracerDAQ by selecting Programs ���� Measurement Computing ���� TracerDAQ ���� TracerDAQ from the Start 

menu.
3. From the TracerDAQ dialog, select Strip Chart, and click on Run. The strip chart application opens.
4. Select New... from the File menu. The DAQ Hardware Settings dialog opens.
5. From the first row of the DAQ Device column, select the DEMO-BOARD from the list-box. Click here for an example.

The drop-down list shows the device ID and device name for all boards that are configured by InstaCal. When you 
select a device, the first channel and range supported by the device appear in the DAQ Channel and DAQ 
Range/Mode columns.

6. Right-mouse click on the first column, and select AutoFill All from the popup menu. The dialog automatically becomes 
configured to acquire data from four channels on the DEMO-BOARD.

Click here to see the dialog configured to acquire data from four channels on the DEMO-BOARD
7. Click on the OK button to save the settings and close the dialog.
8. From the Edit menu, select Scan Rate/Trigger Settings…. The Scan Rate/Trigger Settings dialog opens. 

9. Change the Acquire data for settings so that the scan runs for 5 seconds.

Click here to see the dialog configured to acquire data for 5 seconds.

10. To view plots that don't overlap, click on the scale mode hotspot ( ) on the left side of the strip chart window until it 
turns to  (non-overlap mode).

11. Click on the OK button to save the settings and close the dialog.

12. Click the Run button ( ) on the strip chart.

The strip chart acquires and displays data from the first four channels (0 - 3) of the DEMO-BOARD. 

 

That's all there is to it! The strip chart provides many options for working with strip chart data and customizing the strip 
chart display. Refer to the topics in the Table of Contents for more information.
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Configuring DAQ hardware for the strip chart
You can acquire data from Measurement Computing data acquisition hardware that supports analog input, temperature 
input, digital input and/or counter inputs.

You set up your hardware configuration with the DAQ Hardware Settings dialog. Use this dialog to configure the 
hardware, channels, and range used to acquire data. You can also use this dialog to filter specific input types, and set up 
options for external hardware digital triggering.

The first time you run the strip chart, the dialog opens without any configuration information. Dialog tool tips advise you of 
the action to take.

You must stop the strip chart must be stopped for you to configure DAQ hardware. You cannot configure hardware when the 
strip chart is running or paused.

DAQ hardware settings

To configure your DAQ hardware:

1. Stop the strip chart if it is running.
2. Select DAQ Hardware Settings from the Edit menu (or select File > New). The DAQ Hardware Settings dialog 

opens.
3. By default, the dialog opens by default with four channels to configure. To change the number of channels, right-click in 

the first column and select Number of Channels. Enter the desired number of channels in the dialog that opens, and 
click OK.

4. In the DAQ Device column, select a hardware device from the drop-down list.

The drop-down list shows all boards that are configured by InstaCal. The list includes a device ID and a board name. 
The device ID is the board number assigned by InstaCal. For example, the device ID "Dev0" indicates board number 0.

When you select a device, the first channel and range supported by the device appear in the DAQ Channel and DAQ 
Range/Mode columns.

5. Review the channel listed in the DAQ Channel column. If the hardware supports additional channels, you can select a 
different channel number from the drop-down list.

You can specify which input types to list in the DAQ Channel column using the DAQ Selection Filter list box.
6. Review the range listed in the DAQ Range/Mode column. If the hardware supports additional ranges, you can select a 

different range from the drop-down list.

You can quickly configure the remaining channels to acquire data from the same hardware by using the context menu: 
Right-click in the first column of the first row and select AutoFill All. The hardware, channels, and range information 
populate the rows for the remaining channels.

7. If you want to externally trigger the acquisition, click on the HW Trigger tab.

¡ In the Trig Device column, select the hardware to use as the trigger source. The drop-down list shows all 
Measurement Computing hardware that you can use to trigger the acquisition.

¡ In the Trig Source column, select the signal to use as the trigger source. The drop-down list shows the signals on 
the hardware that can be used use to trigger the acquisition, such as TRIGIN or AUXIN0.

¡ In the Trig Edge column, select the edge to trigger on. Choices are Positive and Negative.

8. Click OK when you are done configuring your hardware. 

The OK button is disabled if the dialog contains invalid entries. 

Note: By default, the previous hardware configuration is loaded each time you open the dialog or launch the strip chart. To 
open the dialog without a hardware configuration, uncheck the Load last configuration option on the Strip Chart
Preferences dialog.

Context menu

You can right-click in the first column (Channeln) of the DAQ Hardware Settings dialog to display a context menu. Use the 
options on this menu to change the number of channels, configure or clear selected rows automatically, undo the last action, 
and redo the last action (when the last action was undone).
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C lick here for an explanation of the options on this menu.

Page 17 of 106

javascript:kadovTextPopup(this)


Saving a strip chart configuration file
You can save the strip chart hardware settings and display settings to a configuration file (*.scc). The file is saved in binary 
format in the location specified by the Configuration file path option in the Strip Chart Preferences dialog.

You can select from a list of pre-defined names, or enter a custom name for the configuration file. You can load each 
configuration file you save to restore the hardware and display settings on the strip chart.

To save current strip chart hardware and display settings to a configuration file:

1. Select Save Configuration from the File menu. The following menu options open.

2. Click on one of the pre-defined file names (User0 to User7) with which to save the file, or select Named 
Configuration to enter another name.
If you select one of the pre-defined options (UserN), the configuration information is automatically saved to a file with 
that name (UserN.scc).

If you select the Named Configuration option, a Save As dialog opens. Enter a name for the file (and change the 
location if you want), and then click Save to save the configuration file.

You can update the configuration file with any changes you make to the hardware settings or display settings by saving the 
configuration again with the same file name.

For information on loading a saved configuration file on the strip chart, go to Loading a strip chart configuration file.
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Loading a strip chart configuration file
You can load a strip chart configuration file (*.scc), and apply the settings to the current strip chart session.

When loaded, the hardware settings and display settings that are stored in the configuration file are applied to the strip 
chart. The name of the configuration file that you load is shown in the title bar of the strip chart. 

Configuration files are stored in the location specified by the Configuration file path property in the Strip Chart
Preferences dialog.

To load a configuration file:

1. Select Load Configuration from the File menu. The following menu options open.

2. If the configuration file was saved using one of the predefined names (User0 to User7), you can select one of these 
from the menu.

Or, click on Named Configuration to select a configuration file from an Open dialog.

The strip chart updates with the hardware and display settings that are stored in the configuration file. The name of the 
configuration file appears in the title bar of the strip chart.

For information on saving a configuration file, go to Saving a strip chart configuration file.
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Setting strip chart preferences
You can set various "preference" options that specify

n where the strip chart stores data and configuration files

n what configuration is loaded when you run the strip chart

n whether other strip chart windows automatically open when you run the strip chart, and how those windows behave in 
respect to the Strip Chart window 

n whether or not annotations are displayed on the strip chart

n whether or not logging and dialog tool tips are enabled 

n what measurement values to show on the Strip Chart Measurements window.

You can set strip chart preferences by selecting Preferences... from the File menu to open the Strip Chart Preferences 
dialog. The dialog is shown here configured with the default settings for TracerDAQ Pro.

If you are running TracerDAQ, the following options are disabled on this dialog:

n Display annotations check box

n Measurements check box

n Maximum, Minimum, Mean, and Current Value check boxes.

The start up options are stored in the system registry in HKEY_CURRENT_USER\Software\Measurement 
Computing\TracerDAQ\Preferences\StripChart.

 

Menu item Description

Configuration file 
path

Sets the directory to store configuration files (*.scc). The default path is:

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Config

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Config

Click the Browse button to select a different location.

Data file path Sets the directory used to store strip chart history files (*.sch). 

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Data

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Data

Click the Browse button to select a different location.
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Data logger file path Sets the directory used to store logger data files.
n For Windows 2000 and Windows XP, the default path is C:\Documents and 

Settings\<User Name>\Application Data\Measurement Computing\TracerDaq\Data 
Logger

n For Windows Vista, the default path is C:\ProgramData\Measurement 
Computing\TracerDaq\Data Logger

Click the Browse button to select a different location.

Data precision in CSV 
files

Sets the digits of precision applied to csv data.

Enable logging When checked, acquired data is automatically saved as a history file (*.sch) to the 
location set by the Data file path option (listed above).

When unchecked (default), data is not automatically saved to a history file. You can 
save data manually using the Save and Save As options on the File menu. 

Load last 
configuration

When checked, the strip chart opens with the hardware configuration that was used 
when you last closed the strip chart.

When Load last configuration is not checked, the settings on the Strip Chart 
Preferences dialog are applied to the strip chart the next time you run the 
application.

Move related views When checked, the Strip Chart Markers window and Strip Chart Measurements 
window (TracerDAQ Pro only) dock to the Strip Chart window. 

When you move the Strip Chart window, the other two windows move with it. 
However, you can move the Strip Chart Markers window and Strip Chart 
Measurements window independently of the Strip Chart window.

Display annotations When checked, annotations appear on the strip chart of each lane.

You can toggle annotations on and off during a scan session by selecting 
Annotations from the View menu.

Show tool tips When checked, tool tips are enabled on strip chart dialogs.

You can toggle tool tips on and off by selecting Tool Tips from the View menu.

Measurements 
(TracerDAQ Pro only)

When checked, the Strip Chart Measurements window automatically opens when 
you run the strip chart.

You can toggle this window on and off during a scan session by selecting 
Measurements from the View menu.

Markers (TracerDAQ 
Pro only)

Note: This check box is enabled in TracerDAQ Pro only.

When checked, the Strip Chart Markers window automatically opens when you run 
the strip chart.

You can toggle this window on and off during a scan session by selecting Markers 
from the View menu.

Maximum (TracerDAQ 
Pro only)

When checked, the maximum value of each enabled channel shows on the Strip 
Chart Measurements window.

Minimum (TracerDAQ 
Pro only)

When checked, the minimum value of each enabled channel shows on the Strip 
Chart Measurements window.

Mean (TracerDAQ Pro 
only)

When checked, the mean value of each enabled channel shows on the Strip Chart 
Measurements window.

Current Value 
(TracerDAQ Pro only)

When checked, the current value of each enabled channel shows on the Strip Chart 
Measurements window.
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Using strip chart timebase controls
You can change the timebase value when acquiring or viewing data on the strip chart. The timebase is represented on the 
strip chart by each major horizontal division. There are ten major horizontal divisions. 

Timebase settings range from 1 µS to 100 days.
The current timebase setting appears in the upper right corner of the strip chart, next to the timebase hotspot controls. 

The following example shows data plotted with a timebase of 100ms:

n Increase the timebase to show more data points on the strip chart. The following example shows the data plotted with a 
timebase of 500ms.

n Decrease the timebase to show fewer data points on the display. The following example shows the data plotted with a 
timebase of 50.0ms.

Using hotspot controls to change the timebase setting
The easiest way to change the timebase setting is with the TIMEBASETIMEBASETIMEBASETIMEBASE hotspot controls.

Click the up/down arrows to scroll through the timebase settings. The current timebase setting appears to the left of the 
up/down arrows. The strip chart updates as the timebase changes.  

You can also use a mouse wheel to change the timebase setting. Scroll the mouse wheel backward to decrease the 
timebase, or forward to increase the timebase. 

Hold down the Shift key to change the timebase setting in multiples of 10. For example, when you change the timebase 
while holding down the Shift key, the value changes from 1.00s to 10.0s, 100s, 1000s, etc.

Auto mode
When you enable Auto mode, the timebase value setting automatically increases when the strip chart acquires enough 
data to fill 50% of the screen for the next timebase setting scale. This is done in order to show all of the data points. 

You set the timebase to Auto mode by clicking on the AAAA  hotspot. 
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Using the Strip Chart Display Settings dialog to change the timebase setting
You can also change the timebase setting by selecting Display Settings from the Edit menu, and changing the Timebase 
option on the Strip Chart Display Settings dialog.
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Scaling channel data on the strip chart (TracerDAQ Pro only)
You can scale data when the strip chart is acquiring or playing back data. When data is scaled, the upper and lower range 
limits are calculated using multiplier and offset values that you specify. 

To enable scaling for each selected channel, do the following:

1. Stop the strip chart if it is running.
2. Select Channel Settings from the Edit menu to open the Strip Chart Channel Settings dialog.
3. Click on the Scaling tab to set scaling options.
4. Click on the channel number(s) for which you want to enable scaling.
5. Click in the Enable scaling check box.
6. In the Multiplier text box, enter the value used to multiply each data point.
7. In the Offset text box, enter the value used to offset each data point.

When you click the run button ( ), the data is scaled using the specified scale factors and plotted on the strip chart. The 
scale mode updates to "Fixed" when the scaled data is plotted in the lane.

For example, a device is configured with a range of +/-5V. When the data is scaled using a multiplier of "3" and an offset of 
"0.5", the upper and lower range limits change to +15.5 and -14.5. 

Saving data that has been scaled

When you save data that has been scaled, the scale factor applied to the data is saved. When viewed as a history file, you 
can turn off channel scaling to view the data at its original unscaled state.
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Zooming in on strip chart data
When you stop the strip chart, you can zoom in on plot lines to get a closer look at the data.

n When only one lane of data is visible on the strip chart, click in the lane and drag a "lasso" around the data region where 
you want to zoom in on.

n When more than one lane is visible on the display, first double-click in a lane to bring it into full view. Then click in the 
lane and drag a "lasso" around the data region where you want to zoom in on.

When you zoom in on one lane, the remaining lanes are hidden. You can double-click again to restore the view to show all 
lanes.

When you release the left mouse button, the zoomed area fills the lane. The strip chart adjusts the timebase setting so that 
the zoomed area fills the lane, and the Y axis is scaled to best fit the zoomed area. You can zoom in on data multiple times.  

n When the lane's Scale mode is set to Fixed or Auto, the zoomed area fills the lane. The timebase setting is adjusted so 
that all data displays in the lane.
When the scale mode is set to Auto and you zoom in on data, the range style is set to Fixed in order to set the upper and 
lower limits to values that best fit the data. The range style is restored once the zoom returns to normal.

n When the scale mode is set to NonOverlapped, all channels within the lasso area are scaled and spaced evenly. Once a 
single channel is displayed in non-overlapped mode, you can zoom in further. 

When you zoom in, the scale mode is set to Fixed. The scale mode is restored once the zoom returns to normal.

Tip: After you zoom in on data, you can hold down the Ctrl key to drag zoomed-in data around the strip chart. This is 
useful for showing data that was not visible on the strip chart when you initially zoomed in.

Zooming out

To zoom out, right-click in the lane. A menu appears with two options - Zoom Out and Zoom Normal. 

n Zoom Out: restores the horizontal and vertical scale settings to the previous zoom setting. 

n Zoom Normal: restores the horizontal and vertical scale settings to normal strip chart view.
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Entering or viewing annotations on the strip chart
The strip chart includes annotations that indicate when the state of acquisition and logging has changed. An annotation 
symbol appears in each lane when you start, pause, or stop a scan operation.

With TracerDAQ Pro, you can also add your own annotation to the strip chart.

The strip chart logs the date and time of each annotation in the Annotation dialog. You can use this dialog to review the 
annotation list, enter a new annotation, and add notes to annotations. You can also select an annotation and point to its 
location on the plot. 

Any error condition that occurs is automatically added to the annotation list, along with a description of the error. 

To open the annotation dialog, put your cursor in a lane and enter the key combination Shift + left mouse click.

Annotation symbols

Each strip chart lane has three labels at its left edge - USR, LOG, and DAQ. Click here for an example. These labels indicate 
the type of annotation and the position in the lane where the annotation appears.

n USR: Annotations that you enter show on the strip chart at the top of each lane. You can toggle these annotations on and 
off during a scan session using the Annotations option from the View menu.

n LOG: Changes to the logging status appear in the middle of each lane.

n DAQ: Changes to the acquisition status appear at the bottom of each lane.

Annotation symbols appear in each lane when acquisition starts, pauses, resumes, and stops:

n  Data acquisition and logging starts.

n  Data acquisition and logging is paused. If the start button is pressed again, the symbol  appears to indicate that 
acquisition is resumed.

n  Data acquisition and logging has stopped.

n  Error condition. If an error occurs, the error name and description is logged to the annotation list, and a red bar 
appears in the DAQ area of the plot at the location where the error occurred. 

The example below shows an acquisition start, pause and resume, and stop. 

The annotations logged for this operation are shown below.

You cannot edit or delete annotations that are automatically logged by the strip chart. 

When you select an annotation, the GoTo text in the upper right corner is enabled. When you click GoTo, the dialog points 
to the annotation symbol on the plot.
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You can turn the annotation symbols on and off by selecting Annotations from the View menu. When Annotations is 
checked, the annotation symbols are visible on the strip chart.

Entering an annotation (TracerDAQ Pro only)

You must acquire data before you can enter an annotation. If the file you are viewing is a previously saved history file, you 
must be in Edit and Save mode before you can enter an annotation.

To enter an annotation for display on the strip chart:

1. With your cursor in a lane, hold down the Shift key and click the left mouse button.
The Annotation dialog opens with a text box for you to enter a label and comment. A pointer at the top of the dialog 
points to the location in the lane where the label will show on the strip chart. 

 

Click here for a summary of the properties on this dialog.
2. Enter text in the Label text box. You can also enter text in the Comments area. Comment text appears in the Notes 

column of the annotation list.
3. Click on Apply. The annotations list appears with the text you entered highlighted. The example below shows a label 

with the text "Conn error" highlighted in the annotations list.

You can scroll to the right to see the Notes column.

n To change the label text, click Edit to return to the Label text box. 

n To remove the label from the strip chart and the annotations list, click Remove.

n To hide all labels from appearing on the strip chart, click in the Display Annotations check box. When unchecked, 
the annotations that you enter are not shown on the strip chart.

n To point to the location of a specific annotation on the strip chart, select the annotation and then click on GoTo. The 
pointer at the top of the dialog points to the location on the display.

4. Click on Exit to close the dialog. 
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Saving strip chart data to a file
There are two ways to save data that you acquire on the strip chart:

n Automatically log data to a history file (*.sch) as it is acquired on the strip chart

n Manually save data to a history file (*.sch) using the Save or Save As menu options. You can save data as a history file 
(*.sch) or as an ASCII text file (.csv or .txt) 

Logging strip chart data to a history file (.sch)

When logging is enabled, the strip chart automatically saves data in the strip chart memory buffer to a history file (*.sch). 
The logging status appears on the display as either "Logger on" or "Logger off".

Data is saved in binary format in the location specified by the Data file path property in the Strip Chart Preferences 
dialog. The file name assigned to the file is internally generated, and uses the format "MMM dd yyyy, hh_mm_ss.fff tt".

If you pause the acquisition before it is complete, the strip chart saves the data to a history file, and then automatically 
updates the file when the scan is finished.

If you disable logging during a scan session, you can select Save from the File menu to update the file previously saved 
when logging was enabled.

Manually saving strip chart data to a file (.sch, .csv, .txt)

When logging is disabled, you can save strip chart data using the Save or Save As menu options. When you do this, a 
Save As dialog opens for you to enter a file name and location with which to save the file. If no data is shown on the 
display, these menu options are disabled.

When logging is turned off, you can save strip chart data as a binary history file (.sch) or as an ASCII text file (.txt or .csv):

1. Select Save or Save As from the File menu.

The Save As dialog opens. By default, this dialog points to the location specified by the Data file path property in the 
Strip Chart Preferences dialog.

2. In the File name text box, enter the name to save the file.
3. In the Save as type list box, select the format used to save the file (.sch, .csv, or .txt).

When saving as an ASCII text file, the numeric and list separators are based on the current Windows settings that are 
set on the computer.
The number of significant digits to display in *.csv files is set by the Data precision in CSV files option in the Strip Chart 
Preferences dialog.

4. Click the Save button.

The next time you select Save..., the file you created is overwritten with the new data.
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Opening and plotting saved scan data on the strip chart
Strip chart data that you save as a history file is assigned the extension *.sch. You can open any history file and plot its 
contents on the strip chart.

When you open a history file, the strip chart enters History mode. The DAQ status area of the display shows "History". In 
History mode, you can change channel and display settings, the timebase value, and add annotations to the display. 

You cannot change the hardware configuration, scan rate, trigger, alarm, or measurement options, or apply channel scaling. 
In History mode, the following Edit menu items are disabled:

n DAQ Hardware Settings

n Scan Rate/Trigger Settings

n Alarm Settings

n Measurement Settings 

History mode has two sub-modes: Review Only (default), and Edit and Save. 

n In Review Only mode, you cannot save changes to the history file. ReviewOnly appears next to HistoryHistoryHistoryHistory in the DAQ 
status area. The File > Save menu option is disabled. You can save changes to the history file using the File > Save As 
menu option.

n In Edit and Save mode, your changes to the history file are automatically saved. Edit&SaveEdit&SaveEdit&SaveEdit&Save appears next to 
HistoryHistoryHistoryHistory in the DAQ status area.

Opening a history file
To open a history file:
1. Select Open from the File menu to display an Open dialog.

By default, this dialog points to the location specified by the Data file path property in the Strip Chart Preferences 
dialog.

2. Select the history file to open, and click the Open button.

The data in the file is plotted on the strip chart in Review Only mode. An example is shown here.

When the strip chart is in History mode, the Playback Start button is enabled to play back the history data. Click here 
to see the display during playback of a history file.

In Review OnlyReview OnlyReview OnlyReview Only mode you cannot save any changes you make to the history data.
3. If you want to edit the history file, click on the EEEE  hotspot at the top of the display. The mode changes to Edit&SaveEdit&SaveEdit&SaveEdit&Save. 

The hotspot changes to .

Any changes you make in this mode are automatically saved as the changes are made.
4. Select Close from the File menu to close the history file.
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Playing back scan data on the strip chart
You can play back data immediately after it is acquired. You can also play back a previously saved data file, such as a 
history file (*.sch), binary file (*.bin), or text file (*.csv or *.txt). When playing back data, the strip chart is in Playback 
mode.

The easiest way to play back data is to use the Playback hotspots on the strip chart:

The Playback Start hotspot is enabled when an acquisition is completed, or when you are viewing data from a previously 
saved file. 

You can also use the Playback options on the Action menu to play, pause, and stop playback on the strip chart.
When playing back data, you can increase or decrease the speed of playback, and go to different areas of the scan using 
the Playback scroll bar. 

To play back data on the strip chart:
1. Click on the Playback StartPlayback StartPlayback StartPlayback Start hotspot. 

The data begins to play back on the display. The Playback PausePlayback PausePlayback PausePlayback Pause and StopStopStopStop hotspots are enabled during playback.
2. Click the Playback SpeedPlayback SpeedPlayback SpeedPlayback Speed buttons to increase or decrease the speed at which the data is playing back. The speed is 

changed by multiplying the original data rate by one of these values: 0.001, 0.01, 0.1, 1.0, 10, 100, 1000. 

n Click the "+" or "-" button to scroll through these values and change the speed. 

3. Click and drag the Playback Playback Playback Playback ScrollbarScrollbarScrollbarScrollbar to go to different points on the scan.

n Scroll to the left to move the display towards the start of the acquisition.

n Scroll to the right to move the display towards the end of the scan.

You can also use the keyboard arrow keys to move the display. Press the left arrow to move the display towards the 
start of the acquisition, or the right arrow key to move the display towards the end of the scan.

4. To pause the scan during playback, click the Playback PausePlayback PausePlayback PausePlayback Pause button.
5. To stop the scan while it is playing back, click the Playback StopPlayback StopPlayback StopPlayback Stop button. The playback will automatically stop when 

the end of the scan is reached.

You can click the PLY hotspot to toggle Playback mode on and off. When viewing history data, the PLY hotspot is disabled 
on the strip chart.

Page 30 of 106



Plotting data from a logger file (.bin) on the strip chart
You can import and plot binary data that was logged to a CF card using the USB-5200 series data loggers. 

TracerDAQ can import a file size containing up to 32K samples for up to eight channels. TracerDAQ Pro can import a file 
size containing up to 1M samples.

You select the channels contained in the binary file that you want to plot, and the number of the lane to plot the data. You 
can plot all of the samples or specify the range of data to plot. If temperature data is contained in the file to import, you can 
specify the unit to display the data.

To import a binary log file:

1. Select Import > Data Logger File from the File menu. The Import Data Logger File dialog opens.
2. In the Source file text box, enter the path and name of the file to import. Click on the Browse button to navigate to 

the directory containing the binary log file to import.
The channel data contained in the selected file appear in the Available channels area. Use the arrow buttons to move 
the channels between the Available channels list and the Selected channels list. The double arrow button moves all 
files to the list in the direction of the arrow.

3. Select the channels to plot from the Available channels list, and click the right arrow button to move the highlighted 
channel(s) over to the Selected channels list.

At least one channel must be in the Selected channels list before the OK button is enabled.
4. In the Lane drop-down list box, select the number of the strip chart lane to display the selected channel data.  

¡ TracerDAQ supports two lanes.

¡ TracerDAQ Pro supports eight lanes.

To plot additional channels in other lanes, select a different lane number from the drop-down list box, and select the 
channel(s) to plot in the lane from the Available channels list. Use the arrow buttons to move the channel(s) to the 
Selected channels list. When you select a lane number, only those channels selected to plot in that lane appear in the 
Selected channels area.

5. Select the range of data to import. You can select all of the data or specify a range of data.

¡ TracerDAQ can import a file size containing up to 32K samples for up to eight channels.

¡ TracerDAQ Pro can import a file size containing up to 1M samples.

Entire File: Imports all samples for the selected channels.

Range: Imports a range of data. Selecting this option enables the Start date, End date, Start time, and End time options.

¡ Start date and End date: Specify the time range of data to import - click the down arrow and select a date from the 
calendar that appears. The available date range is set by the dates of the data in the file. You cannot set the End 
date option to a date that is before the Start date option.

¡ Start time and End time: Specify the time range of data to import - enter the time or use the arrow keys to set the 
time. The available time range is set by the time stamp of data in the file. You cannot set the End time option to a 
time that is before the Start time option.

¡ Click on the Reset Range button to reset default range values. 

6. If the file contains analog input data with units set to temperature, you can select the temperature unit to convert the 
data:

n Celsius: shows temperature data in °C.

n Fahrenheit: shows temperature data in °F.

n Kelvin: shows temperature data in °K.

The temperature unit is applied to analog input channels whose units are set to temperature. If the data logged is 
unscaled (raw data), then the data returned is unscaled (raw data), and no scaling is applied.

7. Click OK to import the data. A dialog appears if the number of samples exceeds the limits of the strip chart (32K 
samples for TracerDAQ, 1M samples for TracerDAQ Pro). 

The selected channel data is plotted on the strip chart. You can play back the data, print the display, and add annotations to 
the data. 

Note: When you import binary log data, the following Edit menu items are disabled:

n DAQ Hardware Settings

n Scan Rate/Trigger Settings

n Alarm Settings
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Plotting data from a text file (.txt or .csv) on the strip chart
You can plot data from a .txt or .csv* (comma separated values) file on the strip chart.

*Including csv data that was converted with InstaCal from binary files, such as those logged from USB-5200 series data 
logger devices.

TracerDAQ can import a file size containing up to 32K samples. TracerDAQ Pro can import a file size containing up to 1M 
samples.

You select the channel data that you want to plot, and the lane number used to plot the data. You can plot all of the data or 
specify a range of data to plot.

To import a text or csv file:

1. Select Import > Text File (.txt, .csv) from the File menu. The Import Text File dialog opens.
2. In the Source file text box, click on the Browse button and navigate to the directory containing file.
3. Select a file to import and click on the Open button.

A preview of the selected file's contents appears in a File Preview window. Use this window to:

¡ Identify the number of header rows, if any, included in the text file.

¡ Review the column data contained in the file.

¡ Note the delimiter character used to separate data in the file. You select the delimiter character using the Specify 
a delimiter list box; it is not set automatically.  

The preview window does not list all of the data in the file. An example of a text file with eight lines of header 
information is shown here.

4. Click on the line that you want the strip chart to start reading from, or enter the number in the numeric up/down 
control. When you click on a line, the numeric up/down control automatically updates with the number of the row you 
select.

5. Use the Specify a delimiter list box to select the delimiter used to separate data in the selected file. Select from 
Comma, Space, Tab, and Semicolon.

6. Click on the OK button.

The File Preview window closes. The column data contained in the selected file appears in the Available channels 
area of the Import Text File dialog. Click here for an example. Note that the number of the line to start reading from 
is listed in the First lines to start from option.

7. Select the column(s) to plot from the Available channels list, and click the right arrow button to move the highlighted 
channel(s) over to the Selected channels list. The double arrow button moves all of the channels in the direction of 
the arrow. 

At least one channel must be in the Selected channels list before the OK button is enabled.
8. In the Lane text box, select the number of the strip chart lane where you want to display the data. 

¡ TracerDAQ supports two lanes.

¡ TracerDAQ Pro supports eight lanes.
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To plot additional channels in other lanes, select a different lane number from the drop-down list, and select the channel
(s) to plot in that lane from the Available channels list. Use the arrow buttons to move the channel(s) to the 
Selected channels list. When you select a lane number, only those channels selected to plot in that lane appear in the 
Selected channels list.

9. Select the range of data to import. TracerDAQ can import a file size containing up to 32K samples. TracerDAQ Pro can 
import a file size containing up to 1 M samples.

Entire File: Imports all data for the selected channels. 

Range: Imports a range of data. Selecting Range enables the Number of lines to read from option.

¡ First line to start from: The line number in the file to start reading data. This option lists the value selected from the 
File Preview dialog. You can change this number by selecting Range radio button and entering a new number.

¡ Number of lines to read from: Enabled when the Range property is selected. Enter the number of samples to read in 
the file. By default, this value is set to the total number of samples in the file minus the starting line.

¡ Click on the Reset Range button to reset default range values.

13. Click OK to import the data. 

A dialog opens if the number of samples exceeds the limits of the strip chart (32K samples for TracerDAQ, 1M samples 
for TracerDAQ Pro). 

The selected channel data is plotted on the strip chart. You can play back the data, print the display, and add annotations to 
the data. 

Note: When you import a text or csv file, the following Edit menu items are disabled:

n DAQ Hardware Settings

n Scan Rate/Trigger Settings

n Alarm Settings

If the strip chart cannot convert data in the text file

If the strip chart is unable to convert the data, a dialog opens with the line number and value that failed the conversion. An 
example is shown here:

If the strip chart is unable to convert the data read from the text file, a dialog opens with the line number and value that 
failed the conversion. For example, if the first line in the File Preview window above is selected as the first line to start 
reading, the following error message opens:

Click on the OK button to return to the Import Text File dialog.

n If the data value is in one of the columns, remove the column from the Selected channels list.

n If the data value is part of the header information, change the number in the First line to start from option.

n Verify that you selected the correct delimiter that is used to separate data in the file.

Once you have updated and/or verified the line to start from, delimiter character, and selected channels, try to import the 
file again.

The scan rate is calculated by determining the time span between the first and last sample in the file, divided by one 
less the number of samples in the file.

The strip chart converts each column of sample data in the Selected channels list to a floating point value.
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Printing a strip chart image
You can preview and print a screen capture of the data currently on the strip chart.

n To preview the screen capture, select Print Preview from the File menu.

A Print preview window opens, from which you can zoom in on the image and then print it.

 - Click on this icon to zoom in (150% to 500%) or zoom out (10% to 75%) on the strip chart capture. 

 - Click on this icon to print the strip chart capture to your default printer. The screen capture always prints in a 
landscape orientation, and fits to the size of your paper and not to the current zoom setting.

n When you are done previewing and printing, click on the Close button.

n To print the image without previewing, select Print from the File menu.

A Print dialog opens. Review the settings on the dialog and click OK to print the image to your default printer.
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Capturing an image of the strip chart (TracerDAQ Pro only)
You can capture an image of the strip chart as a bitmap and store it on the Windows clipboard.

To capture a strip chart image, select Copy to Clipboard from the Edit menu.

The image is copied to the clipboard and remains there until you paste the image or select the copy option again.

You can paste the image into any document that supports bitmap (*.bmp) images.
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Clearing data from the strip chart
Data acquired by the strip chart is stored in a memory buffer until it is saved or cleared. 

1. To clear all data acquired by the strip chart, select Clear Display from the Edit menu
2. Click Yes on the Clear Display dialog.

All data is cleared from the strip chart and from the memory buffer. 

If logging is enabled when you clear the strip chart, all data acquired up to that point is automatically logged to a history 
file. 

The strip chart assigns a file name using the format "MMM dd yyyy, hh_mm_ss.fff tt" (for example, "Mar 12 2007, 
10_25_04.272 AM.sch").

The data is saved in binary format in the location specified by the Data file path property in the Strip Chart Preferences 
dialog.
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Setting the strip chart scan rate and trigger mode
You can set the scan rate (in Hz) from 0.0001 Hz up to the maximum speed of the Measurement Computing device used to 
acquire data. By default, scan rate limits are set  to a minimum of 0.0001 Hz and the maximum "continuous" acquisition rate 
of the selected device. 

You set the length of time that you want to acquire data. The maximum timespan of the strip chart is 999 days, 23 hours, 59 
minutes, and 59 seconds.

The maximum number of samples per channel that you can acquire is 32,000 when using TracerDAQ, and 1,000,000 when 
using TracerDAQ Pro. The number of samples to acquire is calculated by the (scan rate) x (acquire time) x (number of 
triggers).

With TracerDAQ Pro, you can trigger the acquisition using an internal software trigger, an external hardware trigger, or a 
timed interval trigger. With TracerDAQ, you trigger the acquisition when you click the Run button ( ).

The strip chart must be stopped for you to set the scan rate and trigger mode. You cannot set these values when the strip 
chart is running or paused.

Setting the scan rate and trigger mode

To set the scan rate and trigger mode:

1. Stop the strip chart if it is running.
2. From the Edit menu, select Scan Rate/Trigger Settings to open the Scan Rate/Trigger Mode dialog. 
3. In the Scan rate (Hz) text box, enter the rate to use when acquiring data. 

If you enter a rate that exceeds the limits (minimum and maximum), a message appears in the dialog's status bar. You 
must enter a rate that is within the minimum and maximum limits before you can continue.

 

Acquiring data from multiple devices: When acquiring data from multiple devices, the strip chart sets the 
maximum scan rate to a value that can be achieved by all of the devices configured in the DAQ Hardware Settings 
dialog.

4. Set the amount of time to acquire data using the Days, Hours, Minutes, and Seconds numeric up/down controls.

The limit on the time span depends on the value of the Scan rate option. The number of samples per channel cannot 
exceed:

¡ 32,000 for TracerDAQ

¡ one million for TracerDAQ Pro

5. Select the trigger mode from the Trigger Select area. 

The Internal, External, Time Interval trigger modes are only available with TracerDAQ Pro.

     
 
 

   
 
 

    
 
 
  
 
 

   
 

       
 

  

  

  

 
 

    

     
         
          
   

Acquire data from: Sampling rate 

(per device speed)

High speed USB 2.0 Full speed USB 1.0 Low speed USB 1.0

Hardware-paced Ai only Maximum "continuous" rate Maximum "continuous" rate Maximum "continuous" rate

Hardware-paced Ai with 
software-paced Di 

100 Hz 100 Hz 25 Hz

Hardware-paced Ai with 
software-paced Ci 

100 Hz 100 Hz 25 Hz

Hardware-paced Ai with 
software-paced Di and Ci  

100 Hz 100 Hz 25 Hz

Software-paced Di only 100 Hz 100 Hz 50 Hz

Software-paced Ci only 100 Hz 100 Hz 50 Hz

Software-paced Ti only N/A 2 Hz N/A

Software-paced Ti and Di N/A 2 Hz N/A

Hardware-paced Ai and Di Maximum "continuous" rate N/A N/A

Hardware-paced Ai and Ci Maximum "continuous" rate N/A N/A

Hardware-paced Ai , Di 
and Ci

Maximum "continuous" rate N/A N/A

Hardware-paced Ai , Di, Ci 
and Ti

Maximum "continuous" rate N/A N/A
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¡ None: No trigger is configured. Acquisition starts immediately when you click the Run button. You select the scan rate 
and time span to acquire data. None is the only trigger mode enabled in TracerDAQ. The trigger modes listed below 
are only enabled in TracerDAQ Pro.

¡ Internal: Acquisition starts when a strip chart channel reaches a specified value. You select the software trigger 
condition (channel, edge, value), the length of time to acquire data when triggered, the start and stop conditions, and 
timeout, if desired. Internal trigger settings are disabled in TracerDAQ.

¡ External: Acquisition starts on an external trigger. You select the hardware trigger condition (device, signal, edge), the 
length of time to acquire data when triggered, the start and stop conditions, and timeout, if desired. External trigger 
settings are disabled in TracerDAQ.
Latency period: When acquiring data from multiple devices, only one device can be triggered externally. There is a 
latency period between the acquisition of the triggered device and all other configured devices. The length of the 
latency period depends on the configured devices and the overall system speed.

¡ Time Interval: Acquisition runs for a set time and at regular intervals. You select the start condition, time span to 
acquire data, and the time interval between acquisitions. Time Interval settings are disabled in TracerDAQ.

When you select Internal, External, or Time Interval, additional tabs appear on the dialog with the options to set for 
each mode. Click on one of the links below for instructions on setting up the trigger conditions for that mode.

¡ Setting Internal Trigger mode conditions

¡ Setting External Trigger mode conditions

¡ Setting Time Interval trigger mode conditions

The bottom of the dialog lists the scan rate, trigger conditions, and the number of samples per channel to acquire during 
the scan.

6. Click OK when you are done setting the scan rate and trigger options.

The selected trigger mode appears in the Trigger Status area at the bottom of the dialog. When you click the Run button 
with any trigger mode (except None) selected, the DAQ status area next to the Stop button reads "Armed". Data is 
acquired and plotted on the strip chart when the trigger condition is met. The DAQ status area next to the Stop button ( ) 
updates to "Trig'd" as data is acquired.
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Setting strip chart trigger options (TracerDAQ Pro only)
With TracerDAQ Pro, you can set up different trigger conditions for acquiring data on the strip chart. 

Click on the links below to go to instructions for setting trigger conditions for each trigger mode.

n Internal: The acquisition starts when a strip chart channel reaches a specified value.

You select the scan rate, software trigger condition (channel, edge, value), the length of time to acquire data when 
triggered, the start and stop conditions, and timeout period, if desired.

n External: The acquisition starts on an external trigger.

You select the scan rate, hardware trigger condition (device, signal, edge), the length of time to acquire data when 
triggered, the start and stop conditions, and timeout period, if desired.

n Time Interval: The acquisition runs at regular intervals for a set time.

You select the scan rate, start condition, time interval to acquire data, and the time interval between acquisitions.

When you select a trigger mode and run the acquisition, the DAQ status area of the display shows "Armed" and the Trigger 
mode area lists the selected trigger mode. Click here for an example. When the trigger condition is met, the status changes 
to Trig'd while data is acquired.

Use the Scan Rate/Trigger Settings dialog to select the trigger mode and set up trigger conditions. The trigger mode is 
set by default to None. The options on this dialog vary according the trigger mode selected. The bottom of the dialog 
updates with the trigger conditions you select.

Refer to the instructions below to set up trigger mode conditions.

Setting internal trigger mode conditions

To set up internal trigger conditions:

1. From the Trigger Select area, click on Internal. The Scan Rate/Trigger Mode dialog updates with Scan, Arm, and 
Stop tabs.

2. Set the scan rate and trigger conditions using options on the Scan tab:

Click here for an explanation of each option.
3. Set when to start monitoring for the trigger condition using options on the Arm tab:

Click here for an explanation of each option.
4. Set when to stop acquiring data using the options on the Stop tab:

Click here for a summary of the options on this tab.
5. Click OK when you are done setting internal trigger mode conditions.

Setting external trigger mode conditions

To set up external trigger conditions:

1. From the Trigger Select area, click on External. The Scan Rate/Trigger Mode dialog updates with Scan, Arm, and 
Stop tabs.

2. Set the scan rate and trigger conditions using options on the Scan tab:

Click here for a summary of the options on this tab.
3. Set when to start monitoring for the trigger condition using options on the Arm tab:

Click here for a summary of the options on this tab.
4. Set when to stop acquiring data using the options on the Stop tab:

Click here for a summary of the options on this tab.
5. Click OK when you are done setting external trigger mode conditions.

Setting time interval trigger mode conditions

To set up time interval trigger conditions:

1. From the Trigger Select area, click on Time Interval. The Scan Rate/Trigger Settings dialog updates with Scan, 
    

     

   
     

   
     

   

 

Calculating the number of samples

You can calculate the number of samples that will be acquired during a scan operation with the equation:

number of samples = (scan rate) x (acquire time) x (number of triggers).

For example, if you set up a scan rate of 500 Hz, a trigger count of 3, and acquire data for 20 seconds, you will acquire 
 10,000 samples per channel at each trigger, for a total of 30,000 samples ((500) x (20) x (3)).

Note: The maximum number of samples per channel that you can acquire is 32,000 when using TracerDAQ, and 
1,000,000 when using TracerDAQ Pro. 

Acquiring data from multiple devices

When acquiring data from multiple devices, only one device can be triggered externally. There will be a period of 
latency between the acquisition of the triggered device and all other configured devices. The time period of this latency 
is dependent on the configured devices and the overall system speed.
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Arm, and Timespan tabs.

2. Set the scan rate and trigger conditions using options on the Scan tab:

Click here for a summary of the options on this tab.
3. Set when to start monitoring for the trigger condition using options on the Arm tab:

Click here for a summary of the properties on this tab.
4. Set the amount of time to acquire data using the options on the Timespan tab:

Click here for a summary of the options on this tab.

 

 

 

 

 
  

  
 

 

 
 
 

Time between triggers may be inaccurate if system date/time is synched to an authoritative time server 

The time between triggers may be inaccurate if your system date and time are synchronized to an authoritative time 
server through the Windows Time service. See your system administrator about enabling and disabling this service.
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Setting strip chart alarm conditions (TracerDAQ Pro only)
Note: Strip chart alarms are only supported in TracerDAQ Pro. Alarm properties are disabled in TracerDAQ.

You can specify an alarm to occur when channel data goes above or below a specified value. When an alarm is triggered for 
a channel, its plot appears with shading on the display in the area that triggered the alarm.

n If channel data goes above the alarm level set for that channel, its plot is shaded from the alarm level on up.

n If channel data goes below an alarm level set for that channel, its plot is shaded from the alarm level on down. 

The strip chart must be stopped for you to set alarm conditions. You cannot set alarm conditions when the strip chart is 
running or paused.

To set up alarm conditions:

1. Pull down the Edit menu and select Alarm Settings. The Strip Chart Alarm Settings dialog opens. 

Note: The Alarm Settings menu option is disabled when an acquisition is running or paused.

Note: Your hardware configuration must be valid before you can set up alarm conditions. If you select the Alarm 
Settings menu option without first configuring your hardware, or the configuration is not valid, a message appears, and 
then the DAQ Hardware Settings dialog opens for you to correct the configuration.

2. In the Number of alarms text box, enter the number of alarms to configure. The maximum number of alarms you can 
set is 64.

A row for each alarm number is automatically added and filled with the default value for each alarm option. For 
example, when you enter "2", two Alarm rows appear on the dialog:

3. Specify the trigger conditions in the row for each alarm.

n Source: select the channel number to monitor for the alarm condition. The available channels are based on the 
channel names configured in the DAQ Hardware Settings dialog.

n Condition: select the alarm condition to monitor. Choices are Greater Than, Greater Than or Equal, Less Than or 
Equal, and Less Than.

n Range: the available range to specify for the alarm level. You cannot change this value. The range is based on both 
the range selected in the DAQ Hardware Settings dialog and the scaling values (if channel scaling is enabled for the 
channel).

n Alarm Level: enter the level at which the alarm will occur. An error message appears in the status bar at the bottom 
of the dialog if you enter an invalid value.

n Color: click on the Color button and select the color of the alarm area on the plot.

A summary of the condition for the selected alarm displays at the bottom of the dialog.
4. Click OK when you are done setting alarm conditions. 

If the display contains existing data, the data is monitored for the alarm condition. For each channel whose trigger condition 
is met, its plot appears shaded in the area which triggered the alarm.

Example

The dialog below shows alarm conditions configured for two channels. Note that the alarm condition set for the selected 
alarm number (Alarm0) is summarized on the dialog.
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When the alarm is triggered, the plot line for that channel displays with shading at the point where the alarm condition is 
met.
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Showing measurements on the Strip Chart Measurements window (TracerDAQ 
Pro only)
When you run TracerDAQ Pro, the Strip Chart Measurements window appears by default with the Strip Chart window. 
The Strip Chart Measurements window does not appear when running TracerDAQ.

The Strip Chart Measurements window lists the values for each channel you plot on the strip chart. You can choose which 
measurement values to show on the window. Choices are:

n Maximum value

n Minimum value

n Mean value

n Current value

The measurement values automatically update for each channel as the strip chart acquires data. The values do not update 
when you play back data.

To select the measurement values to show on the Strip Chart Measurements window:

1. Select Preferences from the File menu to open the Strip Chart Preferences dialog. You select the measurement 
values to show from the Measurements window.

2. Click in the check box for each measurement value you want to list on the Strip Chart Measurements window. The 
value of each selected measurement appears on the window for each channel on the strip chart.

¡ Maximum: check this box to show the maximum value of each channel.

¡ Minimum: check this box to show the minimum value of each channel.

¡ Mean: check this box to show the mean value of each channel.

¡ Current Value: check this box to show the current value of each channel.

When unchecked, the measurement value is not listed on the Strip Chart Measurements window.

3. Click OK when you are done.

Showing and hiding the Strip Chart Measurements Window

You can turn the Strip Chart Measurements Window on and off by selecting Measurements from the View menu. When 
Measurements is checked, the Strip Chart Measurements window is visible.
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Setting strip chart lane options
You can set the number of lanes that you want to appear on the strip chart. TracerDAQ supports two lanes. TracerDAQ 
Pro supports eight lanes. 

You can enter a label to identify the data in each lane, and set the lane number where you want to plot the data. Multiple 
channels of data can be plotted in each lane.

You can also select how to scale the data in each lane. Choose from three scale modes:

n Auto: plot data based on the range of the data values being plotted

n Fixed: plot data based on upper and lower range limits that you specify

n Nonverlapped: plot data based on a "best-fit" method, in which all channel data in a particular lane is evenly scaled in 
magnitude and spacing so as not to overlap.

You can set lane options while the strip chart is stopped with the Strip Chart Display Settings dialog. You can also set lane 
options while the strip chart is running or stopped using hotspots on the strip chart.

Setting lane options while the strip chart is running (hotspots)
You can use strip chart hotspots to change the number of lanes used to plot data, the scale mode, and the upper and lower 
range limits. Do the following:

Change the number of lanes used to plot data on the strip chart:

1. Click on the SETSETSETSET  hotspot. 

2. Click on the DisplayDisplayDisplayDisplay tab and set the User LanesUser LanesUser LanesUser Lanes option with the up/down arrows.

Change the scale mode:

n Click the Scale mode hotspot to toggle through the scale modes:

¡ Fixed: Data is plotted using upper and lower range limits that you specify. You can click on the range limits and enter 

new values in this mode. When the mode is Fixed, the hotspot looks like .

¡ Auto: Data is plotted using the upper and lower limits of the acquired data. When the mode is Auto, the hotspot looks 

like .

¡ NonOverlapped: All channels within a single lane are scaled and spaced evenly. When the mode is NonOverlapped, 

the hotspot looks like .

Change the upper range limit and lower range limit:

1. Click on the Scale modeScale modeScale modeScale mode hotspot and set the mode to "Fixed". This hotspot looks like  when the mode is fixed.
2. Double-click on the upper limit and enter a new value in the text box that appears. Repeat to change the lower limit 

value.

Setting lane options while the strip chart is stopped (Strip Chart Display Settings dialog)
1. Stop the strip chart if it is running.
2. Select Display Settings from the Edit menu to open the Strip Chart Display Settings dialog. 
3. Click on the LanesLanesLanesLanes tab.
4. In the Number of Lanes text box, enter the number of lanes to show on the strip chart.

The number of lanes shown on the strip chart automatically changes according to the number you enter. With 
TracerDAQ Pro, you can enter a number from 1 to 8. TracerDAQ supports two lanes. TracerDAQ Pro supports eight 
lanes.

5. In the lanes list, select the lane number whose options you want to set. Hold down the Ctrl key to select more than one 
lane. Set the following lane options:

¡ Label: Enter up to five characters of text. The label appears vertically in the left edge of the selected lane(s). Click 
here for an example.

¡ Upper limit: Enter the upper range limit used to plot the data. This option is enabled when the Scale mode option is 
set to "Fixed". 

¡ Lower limit: Enter the lower range limit used to plot the data. This option is enabled when the Scale mode option is 
set to "Fixed".

¡ Scale mode: Select the mode used to scale data. You can select a different mode for each lane. Choices are:

l Fixed: Data is plotted using upper and lower range limits that you specify. Enter the upper limit value in the 
Upper limit text box, and enter the lower limit value in the Lower limit text box. When set to Fixed, the Scale 

mode hotspot looks like  on the strip chart. Click here for an example of data plotted using a Fixed range of 
+/- 10. 

l Auto: Data is plotted using the upper and lower limits of the acquired data. When set to Auto, the Scale mode 

hotspot looks like  on the strip chart. Click here for an example of data configured with a range of +/-5V and 
plotted using the Auto scale.

l NonOverlapped: All channels within a single lane are scaled and spaced evenly. When set to NonOverlapped, the 
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Scale mode hotspot looks like  on the strip chart. Click here for an example of two channels plotted in one 
lane using the scale mode NonOverlapped.    

6. Click OK when you are done setting lane options.
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Setting strip chart display options
You can set various display options to control the general appearance and content of the strip chart, such as:

n show the acquisition time or the sample count on the strip chart

n set the length of time that marker position data is visible on the strip chart

n set the timebase used to acquire data

n enable or disable hotspots on the strip chart

n apply a custom color scheme to the strip chart foreground and background, or select the colors yourself

You can set display options while the strip chart is stopped with the Strip Chart Display Settings dialog. You can also set 
display options while the strip chart is running or stopped using the SETSETSETSET  hotspot dialog and the timebase hotspots.  

Setting display options while the strip chart is running (SETSETSETSET  hotspot) 
You can click the SET hotspot and set display options without opening the Strip Chart Display Settings dialog. Do the 
following: 
1. Click on the SETSETSETSET  hotspot. 

2. Click on the Display tab to access display options:

¡ ContrastContrastContrastContrast: sets the color of the lane background. Click the up/down arrows to select a value from 0.0 to 1.0. This 
value blends the foreground and background colors together. The resulting color is used as the lane background 
color. 

¡ ColColColCol Scheme Scheme Scheme Scheme: click the up/down arrows to toggle between pre-defined color schemes applied to the strip chart. 

¡ Fore ColorFore ColorFore ColorFore Color: click on the color block and select the color of the strip chart foreground. 

¡ Back ColorBack ColorBack ColorBack Color: click on the color block and select the color of the strip chart background. 

¡ SelectTimeSelectTimeSelectTimeSelectTime: click the up/down arrows to select the number of seconds that marker data shows on the strip chart.

¡ User LanesUser LanesUser LanesUser Lanes: click the up/down arrows and select the number of lanes to show on the strip chart. If the strip chart 
shows data in two lanes, and you change this option to "1", both data plots are shown in one lane.

3. Click Exit when you are done setting display options.

Changing the timebase while the strip chart is running (Timebase hotspots)

You can also change the timebase value using the Timebase hotspots when the strip chart is running. 

n Click the up and down arrows to scroll through the timebase settings. 

n Click AAAA  to enable Auto mode to automatically change the timebase setting whenever data fills the strip chart.  

For more information about timebase settings, go to the Using strip chart timebase controls topic.

Setting display properties while the strip chart is stopped (Strip Chart Display Settings dialog)
1. Stop the strip chart if it is running.
2. Select Display Settings from the Edit menu. The Strip Chart Display Settings dialog opens. Use the General tab 

to set display options.
3. Specify the Display Settings options:

¡ Selection time: Enter the number of seconds that marker position values and timebase values appear in the upper 
left corner of the strip chart.

¡ Timebase: Select the amount of time between each major grid on the strip chart. Increase the value to show more 
data points on the strip chart, or decrease the value to show less data points on the strip chart. For more information 
about timebase settings, go to the Using strip chart timebase controls topic.

¡ Display format: Select the information to show in the Timespan/Sample count area at the bottom of the strip chart. 
Choices are TimeSpan and Scans:

l TimeSpan: lists the acquisition time count at the bottom of the strip chart. The upper left corner shows the time 
remaining in the acquisition next to the label Time Span Left. Click here for an example.

l Scans: lists the acquisition sample count at the bottom of the strip chart. The upper left corner shows the 
remaining samples in the scan next to the label Samp Span Left. Click here for an example. 

¡ Enable hotspot: Check in this box to enable hotspots on the strip chart. When unchecked, hotspots are disabled. For 
more information on strip chart hotspots, go to the Hotspots on the strip chart topic.

4. Specify the Display View options:

¡ Color Scheme: Select a color scheme from a list of predefined values. The color scheme is applied to the strip chart 
background and foreground. You can also select the colors yourself from the options below. When you select the 
colors, the Color Scheme option is set to Custom.

¡ Contrast: Select a value from 0.0 to 1.0. This value is used to blend the foreground and background colors together 
to create the background color of the strip chart lanes.

       

     

    

Page 46 of 106

javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
javascript:hhctrl.TextPopup('Strip chart hotspots include the DAQ control buttons (run, pause, stop), PLY and SET buttons, timebase controls, scale mode button, playback controls and scrollbar, and markers.','Arial,8',10,10,00000000,0xc0ffff)


 
 

  

  

  

  

  

   
       

       
   
 
        

     

      
 
 

              

       

       

      

      
 

    

 

   

  

          

   

 
  
          

 
     

   
 

   
 
   

     
    

   
     

   
      

         
   

    

   
 
   

   
 

¡ Background Color: Click the Background Color button and select the color of the strip chart background.

¡ Foreground Color: Click the Foreground Color button and select the color of the strip chart foreground.

5. Click OK when you are done setting display options.
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Setting strip chart channel options
You can plot up to 32 channels on the strip chart using TracerDAQ Pro, and up to eight channels using TracerDAQ. 

You can set the following channel options:

n the number of channels to plot

n the lane number used to plot the data

n the channel name

n the channel unit

n the line style and color of the plot line

You can also disable channel data from appearing on the strip chart, and scale channel data.

You can set channel options while the strip chart is stopped with the Strip Chart Channel Settings dialog. You can also set 
channel options while the strip chart is running or stopped using the SETSETSETSET  hotspot dialog.  

Setting channel properties while the strip chart is running (SETSETSETSET  hotspot) 

You can click the SET hotspot and set channel options without opening the Strip Chart Channel Settings dialog. Do the 
following: 

1. Click on the SETSETSETSET  hotspot. 

2. Click on the Channels tab to access channel options:

n ChannelChannelChannelChannel: click the up/down arrows to change the channel (CH0 - CHn) whose options you want to set. 

n NameNameNameName: click on ED (edit) and enter a name in the text box that appears.

n ColorColorColorColor: click on the color block and choose a color from the Color dialog.

n Plot StylePlot StylePlot StylePlot Style: click the up/down arrows to toggle between plot styles. Choices are Solid, Dashed or Dots.

n VisibleVisibleVisibleVisible: click the up/down arrows to toggle between True and False. When True, data is shown on the strip chart. 
When False, data is not shown on the strip chart.

n DestDestDestDest Lane Lane Lane Lane: click the up/down arrows to scroll through the lane numbers (Lanen) on the strip chart.

3. Click Exit when you are done setting channel options.

Setting channel options while the strip chart is stopped (Strip Chart Channel Settings dialog)
1. Stop the strip chart if it is running.
2. Select Channel Settings from the Edit menu. The Strip Chart Channel Settings dialog opens. Use the Settings tab 

to set channel options.
3. In the Number of channels text box, enter the number of channels to plot on the strip chart.

The number of channels in the channel list automatically changes according to the number you enter. TracerDAQ 
supports eight channels. TracerDAQ Pro supports 32 channels.

Note: If you set the number of channels to a value greater than the number of channels configured on the DAQ 
Hardware Settings dialog, you must configure the new channel(s) before you can run the strip chart. If you attempt 
to run the strip chart without configuring the new channel(s), a DAQ input error dialog opens.

4. In the channel list, select a channel number and specify its options using the options on the Settings tab. Hold down 
the Ctrl key to set the options of more than one channel at a time.

¡ Name: Enter a unique name for the channel. This name is shown on the Strip Chart Measurements window and 
on the Strip Chart Markers window. Only one channel can be selected to enter a name. 

¡ Units: Enter a unit for the channel. This unit is shown with channel values on the Strip Chart Measurements 
window. 

¡ Lane: Select the number of the lane where you want to plot the data. You can plot multiple channels in each lane. 
TracerDAQ supports two lanes (Lane0 and Lane1). TracerDAQ Pro supports eight lanes (Lane0 to Lane7).

¡ Plot style: Select the line style used to plot the data. Select from Solid, Dashed, or Dots.

¡ Channel visible: Check this check box to show channel data on the strip chart. When unchecked, data is still acquired 
but is not shown on the strip chart.

¡ Color: Click this button to open a Color dialog and select the color of the plot line. The current selection appears 
next to the button.

5. Click on the OK button when you are done setting channel options.

Scaling channel data while the strip chart is stopped

You can individually scale strip chart data. When data is scaled, the upper and lower range limits are calculated using 
multiplier and offset values that you specify. You can set up channel scaling before you acquire data or after the acquisition 
completes. Do the following:

1. Stop the strip chart if it is running.
2. Select Channel Settings from the Edit menu to open the Strip Chart Channel Settings dialog.
    
    
    
    
    

   

  

   
    

 

Page 48 of 106

javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
javascript:hhctrl.TextPopup('CH8 for TracerDAQ\r\n\r\nCH32 for TracerDAQ Pro','Arial,8',10,10,00000000,0xc0ffff)
javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)


 
 

 

  

  

  

  

  

 

   
       

       

   
 

        

     

           

        

      

            

          
 

             

    

 
  
          

 
    

 
 

   
  
   

    
   

     
   

     
 

   
   

   

   
 

     
 

    

 

  
 
 

  
        
3. Click on the Scaling tab to set scaling options.
4. Click on the channel number(s) for which you want to enable scaling.
5. Click in the Enable scaling check box.
6. In the Multiplier text box, enter the value used to multiply each data point.
7. In the Offset text box, enter the value used to offset each data point.

When you click the Run button, the data is scaled using the specified scale factors and then plotted on the strip chart. The 

scale mode updates to "Fixed" ( ) when the scaled data is plotted in the lane.

For example, a device is configured with a range of +/-5V. When the data is scaled using a multiplier of "3" and an offset of 
"0.5", the upper and lower range limits change to +15.5 and -14.5. 

When you save data that has been scaled, the scale factor applied to the data is also saved.
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Setting strip chart marker options
The strip chart has two markers that you can move to any location on the strip chart to view the values of specific data 
points. The markers are identified on the strip chart as MK0 and MK1.

The value of the data point at each marker's position, and the amplitude difference between the markers for each channel, 
shows on the Strip Chart Markers window.

By default, the markers have a vertical orientation. The left marker is labeled MKO, and the right marker is labeled MK1.

You can set the color of each marker, and whether the marker is visible on the strip chart. You can also change the 
orientation to horizontal when viewing only one lane of data.

When you click on a marker, its position is shown on the upper left corner of the strip chart, and the delta position - the time 
between the two markers - is shown to the left of the Timebase hotspot in the upper right corner. Click here to see an 
example. You can set the number of seconds that these values remain on the strip chart.

When you move the marker on the strip chart, the channel values at the marker's position update on the Strip Chart 
Markers window. Click here for an example.

You can set marker options while the strip chart is stopped with the Strip Chart Display Settings dialog. You can also set 
marker options while the strip chart is running or stopped using the SETSETSETSET  hotspot dialog. 

You can turn the Strip Chart Markers window on and off by selecting Marker Values from the View menu. When Marker 
Values is checked, the Strip Chart Markers window is visible.

Setting marker options while the strip chart is running (SETSETSETSET  hotspot) 

You can click the SET hotspot and set marker options without opening the Strip Chart Display Settings dialog. Do the 
following:

1. Click the SETSETSETSET  hotspot on the strip chart. 

2. Click on the Markers tab to set these marker options:

n MarkerMarkerMarkerMarker: click the up/down arrows to toggle between marker0 (MK0MK0MK0MK0) and marker1 (MK1MK1MK1MK1).

n EnabledEnabledEnabledEnabled: click the up/down arrows to toggle between TrueTrueTrueTrue (marker is visible) and FalsFalsFalsFalse (marker is not visible).

n ColorColorColorColor: click on the color block to open a standard Color dialog.

n OrientationOrientationOrientationOrientation: click the up/down arrows to toggle between VerticalVerticalVerticalVertical and HorizontalHorizontalHorizontalHorizontal. This option is disabled if 
multiple lanes are shown on the strip chart.

3. Click on the Display tab and set the SelectTimeSelectTimeSelectTimeSelectTime option to set the number of seconds that the marker position and 
delta position appear on the strip chart.

n SelectTimeSelectTimeSelectTimeSelectTime: click the up/down arrows to change the time using 1.0 second increments. 

n Tip: Hold down the Ctrl key to change the time using 0.5 second increments.

4. Click Exit when you are done setting marker options.

Setting marker options while the strip chart is stopped (Strip Chart Display Settings dialog)
1. Stop the strip chart if it is running.
2. Select Display Settings from the Edit menu. The Strip Chart Display Settings dialog opens. Click on the Markers 

tab to set marker options.
3. From the list of markers, select the marker number whose options you want to set. Hold down the Ctrl key down to 

select both markers at the same time.

¡ Enabled: Check this checkbox to show the marker on the strip chart. When unchecked, the marker is not visible on 
the strip chart.

¡ Color: Click on the Color button and select the color of the selected marker(s).

¡ Orientation (TracerDAQ Pro only): Select the orientation of the selected marker(s). Choices are Vertical and 
Horizontal. 
This option is disabled when multiple lanes are shown on the strip chart. You can double-click in a lane to show only 
that lane on the strip chart.
With one lane showing on the strip chart, select either Vertical or Horizontal from the drop-down list. Tip: With one 
lane showing on the strip chart, you can double-click on a marker to automatically change its orientation. 

4. Click on the General tab to set the number of seconds that marker values remain on the strip chart.
5. Click the up/down arrows to change the Selection time option using 0.5 second increments.
6. Click OK when you are done setting marker options.
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Introducing the oscilloscope
TracerDAQ's oscilloscope is a virtual graphing application used to acquire analog input data from supported Measurement 
Computing DAQ hardware. The oscilloscope supports the "continuous" maximum speed of Measurement Computing DAQ 
hardware.

With the oscilloscope, you can perform the following tasks:

n Plot up to four channels of data acquired from one or more Measurement Computing DAQ devices with TracerDAQ Pro. 
Plot up to two channels of data acquired with TracerDAQ.

n Trigger an acquisition using an internal software trigger or external hardware trigger

n Individually scale channel data

n Display specific measurement values for each channel

n Change the timebase to view more or less data on the plot

n Add a reference channel (TracerDAQ pro only)

n Add a math channel (TracerDAQ pro only)

n Save a screen of data to an oscilloscope history file (.osh) or text file (.csv and .txt)

n Open and plot an oscilloscope history file

n Save hardware configurations for future use

n Customize the appearance of the oscilloscope

Interactive hotspots on the oscilloscope let you change data display options while the oscilloscope is running. Oscilloscope 
dialogs feature tool tips that explain the function of each option. A status bar on the oscilloscope lets you know the operation 
status, when an option setting is invalid, or if an error condition occurs.

Two movable data point markers let you view data at specific locations on the oscilloscope. The value of channel data at 
each marker position is shown on the oscilloscope.

Oscilloscope Quick Start

For a quick, hands-on exercise that shows you how to acquire and display data using the oscilloscope, click on the Quick 
Start button below.

This quick start exercise shows you how to acquire and plot data from Measurement Computing DEMO-BOARD virtual data 
acquisition hardware. No additional hardware is required.
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Overview of the oscilloscope environment
When you run the oscilloscope application, the Oscilloscope window opens. 

When you are running TracerDAQ Pro, the Oscilloscope Measurements window also opens (shown here).

Both windows are shown here:

n The Oscilloscope window plots the acquired data. Hotspots let you configure data and display settings right on the 
window.

n The Oscilloscope Measurements window shows specific measurement values for each channel configured to acquire 
data. 

This window is only available with TracerDAQ Pro.

Components on the Oscilloscope window

Components on the Oscilloscope window are identified below. Place your cursor over a component name to display a brief 
description.

An asterisk (*) after the name indicates that the component is also a hotspot. or more information about oscilloscope 
hotspots, go to the Hotspots on the oscilloscope topic.
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How the oscilloscope acquires data

The oscilloscope supports the maximum speed of Measurement Computing DAQ hardware. 

The oscilloscope uses a scan function to acquire data from hardware channels. The current value of each data point is reads 
from the scan buffer. All channels on the oscilloscope have the same number of data points in their plots. 

The display update time varies from device-to-device, and may take longer than the acquisition time to acquire the data. 

Error handling

If an error occurs, the oscilloscope stops the acquisition, and displays the error message on its status bar. A dialog of the 
error message also opens. An example is shown here.
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Overview of the oscilloscope menu bar
The oscilloscope menu bar options are explained in the following table.

 

Menu item Explanation

File Includes options you can use to:
n save, open, and close oscilloscope history files (*.osh)
n save or load a configuration file
n preview and print screen captures of oscilloscope data
n set up oscilloscope preference settings

Click on the following button for instructions on how to perform these tasks.

Edit Includes options you can use to:
n configure Measurement Computing data acquisition hardware
n scale oscilloscope data
n set the timebase value
n set up oscilloscope channels, markers, and display settings
n set up trigger conditions
n clear data from the oscilloscope
n copy an image of the oscilloscope to the clipboard (TracerDAQ Pro only)
n set up a math channel (TracerDAQ Pro only)

Note: Most Edit menu items are disabled when the strip chart is running or paused. You cannot 
change hardware, channels or display settings during an acquisition.

Click on the following button for instructions on how to perform these tasks.

View Includes options you can use to:
n reset the timebase, channel scale, and trigger mode values to default settings
n show/hide the Oscilloscope Measurements window (displays specific channel 

measurements)
n enable/disable pop up tool tips on oscilloscope dialogs

Action Includes options you can use to start or stop acquiring data

Help Includes options you can use to:
n open the TracerDAQ online help file
n view TracerDAQ version and contact information
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Hotspots on the oscilloscope
The Oscilloscope window has several hotspots. A hotspot is an interactive area on the oscilloscope that lets you change 
settings while the oscilloscope is running. All hotspots have corresponding dialogs that you access through the oscilloscope 
menu bar to perform the same action.

You can enable and disable hotspots using the Display Settings dialog (Edit > Display Settings). Hotspots are enabled 
when the "Enable hotspot" check box is checked.

The following hotspots are available on the oscilloscope:

 

Hotspot control Description

DAQ controls RunRunRunRun: Starts acquiring data from the configured hardware device(s). 
n Begins monitoring for trigger conditions, if a condition is specified (TracerDAQ Pro 

only).
n This hotspot is disabled while the oscilloscope is running, and enabled when the 

oscilloscope is stopped.

StopStopStopStop: Stops data acquisition and display.
n This hotspot is disabled when the oscilloscope is stopped, and enabled when the 

oscilloscope is running.

MATMATMATMAT : Toggles the math channel on and off. 

SETSETSETSET : Opens a dialog for setting display, channel, math, and marker options. 

TimebaseTimebaseTimebaseTimebase: Sets the time represented by each major horizontal division. There are ten 
major horizontal divisions. Click the up/down arrows to change the value.
n You can set the timebase to 1 µS, 2 µS, 5 µS, 10 µS, 20 µS, 50 µS, 100 µS, 200 µS, 

500 µS, 1 mS, 2 mS, 5 mS, 10 ms, 20 mS, 50 mS, 100 mS, 200 mS, 500 ms, 1 s, 2 
s, 5 s, or 10 s.

n If you have a computer mouse with a wheel, you can roll forward to increase the 
timebase value, and roll backward to decrease the timebase.

n Hold down the Shift key to change the timebase setting in multiples of 10. For 
example, when you change the timebase while holding down the Shift key, the value 
changes from 1.00ms to 10.0ms, 100ms, 1.00s, etc.

For more information on timebase controls, go to the Using oscilloscope timebase
controls topic.

Channel scale mode

 Fixed

 Auto

Toggles the scaling mode for the selected channel between Fixed and Auto.
n FixedFixedFixedFixed: The oscilloscope scales the data to the volts/division value set for the 

selected channel. The up/down arrows are enabled to change the volts/division value.

n AutoAutoAutoAuto: The oscilloscope calculates a scale that best fits the data. The volts/division 
up/down arrows are disabled in Auto mode.

Channel settings Opens the SETSETSETSET  hotspot's CHAN's tab for setting channel options. 

Channel enable

 

Shows or hides channel data on the oscilloscope. 

When the channel is disabled, the Measurement enable, Reference enable, and Trigger 
mode hotspots are hidden on the oscilloscope, and CHn off appears to indicate the 
channel is disabled. An example is shown here:

The channel's marker information is also hidden when the channel is disabled.

When the channel is enabled , the Measurement enable, Reference enable, and 
Trigger mode hotspots show on the oscilloscope.
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Measurement enable

 

When enabled, measurement values show on the Oscilloscope Measurements 
window. When disabled, measurement values show NaN on the Oscilloscope 
Measurements window.

Note: The measurement values that are listed on the Oscilloscope Measurements 
window are based on the options set on the Oscilloscope Preference Settings dialog.

This hotspot also shows and hides marker position values for the selected channel on 
the oscilloscope.

You can enable/disable this hotspot in TracerDAQ Pro only; The Measurement enable 
hotspot is always disabled in TracerDAQ.

Reference enable

 

Right click on this hotspot to create a reference signal for the selected channel. When 
enabled, a reference signal for the channel appears on the oscilloscope. Drag the 
channel marker up or down to see the reference signal. 

Left click on this hotspot to show or hide the reference signal. When hidden, the hotspot 
appears as  on the oscilloscope.

When you enable a reference signal for one channel, hides any reference signals that 
were created for other channels. You can show a channel's reference signal at any time 
by left clicking on the channel's Reference hotspot.

You can enable/disable this hotspot in TracerDAQ Pro only; The Reference enable 
hotspot is always disabled in TracerDAQ.

Trigger mode

 Normal

 Auto

 Single

Sets the associated channel as the trigger source, and sets the trigger mode used to 
acquire data. 
The selected trigger source is shown in the Trigger Status area of the status bar, and the 
trigger mode is shown in the Trigger Mode area at the top of the oscilloscope.

Click this hotspot to toggle through the trigger modes. Select from Normal, Auto, and 
Single. 

NormalNormalNormalNormal: The oscilloscope starts plotting data when the signal reaches the trigger value.

AutoAutoAutoAuto: The oscilloscope automatically starts plotting data after a short amount of time 
(based on the TIMEBASE setting).

SingleSingleSingleSingle: The oscilloscope waits for a trigger, graphs a single sweep of data, and then 
stops. This mode is useful for capturing signals that are not periodic and that occur only 
once.

n The trigger mode hotspot shows as  for all channels on the oscilloscope when the 
trigger mode is set to external using the Trigger source option on the Trigger
Settings dialog. The trigger mode hotspots for all channels are disabled when the 
mode is set to external. 

n The trigger mode hotspot shows as  on the oscilloscope for each channel that is 
not selected as the trigger source.

Internal trigger slope

 rising

 falling

 

Toggles the trigger slope between rising edge and falling edge.

Internal trigger level Sets the level at which the trigger is generated. Drag this hotspot up and down to set the 
trigger level.

The channel number corresponds to the channel selected as the trigger source.

Markers The oscilloscope has two movable markers that you can use to view data at specific 
locations. 

When you scroll the markers from left to right, the value of the data point at each 
marker's position, and the delta position (the time between the two markers) are shown 
on the oscilloscope.
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Quick Start - Plotting DEMO-BOARD signals with the oscilloscope 
As stated in the introduction, you can acquire and display data with TracerDAQ Pro "soon after you install your 
Measurement Computing DAQ hardware."

You can get a feel for what TracerDAQ can do even sooner by trying it out with the DEMO-BOARD, which is a simulated ISA 
board included with InstaCal.

To acquire and plot DEMO-BOARD signals on the oscilloscope, follow the steps below.
1. Make sure you have completed the steps in the "Running InstaCal and adding your hardware" section of the DAQ 

Software Quick Start.
2. Run TracerDAQ by selecting Programs ���� Measurement Computing ���� TracerDAQ ���� TracerDAQ from the Start 

menu.
3. From the TracerDAQ dialog, select Oscilloscope, and click on Run. The oscilloscope application opens.
4. Select New... from the File menu. The DAQ Hardware Settings dialog opens.
5. From the first row of the DAQ Device column, select the DEMO-BOARD from the list-box. Click here for an example.

The drop-down list shows the device ID and device name for all boards that are configured by InstaCal. When you 
select a device, the first channel and range supported by the device appear in the DAQ Channel and DAQ 
Range/Mode columns.

6. Right-mouse click on the first column, and select AutoFill All from the pop up menu. This automatically configures the 
DAQ Device, DAQ Channel and DAQ Range/Mode for the remaining channels on the dialog.

7. Click on the DAQ Range/Mode column's down arrow and select +/-5V. The range automatically updates for the 
second channel.
Click here to see the dialog configured to acquire data from two channels on the DEMO-BOARD. 

7. Click on the OK button to save the setting and close the dialog.

8. On the Oscilloscope window, click on the Start button ( ).
9. The oscilloscope acquires and displays data from the first two channels (0 - 2) of the DEMO-BOARD. 

That's all there is to it! The oscilloscope provides many options for working with oscilloscope data and customizing the 
oscilloscope display. Refer to the topics in the Table of Contents for more information.
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Configuring DAQ hardware for the oscilloscope
You can acquire data from Measurement Computing data acquisition hardware that support analog inputs.

You set up your hardware configuration with the DAQ Hardware Settings dialog. Use this dialog to configure the 
hardware, channels, and range used to acquire data. You can also use this dialog to set up options for external hardware 
digital triggering.

The first time you run the oscilloscope, the dialog opens without any configuration information. Dialog tool tips advise you of 
the action to take.

You must stop the oscilloscope before you can configure the DAQ hardware. You cannot configure hardware when the 
oscilloscope is running.

DAQ hardware settings

To configure your DAQ hardware:

1. Stop the oscilloscope if it is running.
2. Select DAQ Hardware Settings from the Edit menu (or select File > New). The DAQ Hardware Settings dialog 

opens.

By default, the dialog opens with two (TracerDAQ) or four (TracerDAQ Pro) channels to configure. 
To change the number of channels, right-click in the first column and select Number of Channels. Enter the desired 
number of channels in the dialog that opens, and click OK.

3. In the DAQ Device column, select a hardware device from the drop-down list. 

The drop-down list shows all boards with analog inputs that are configured by InstaCal and detected by the Universal 
Library. The list includes a device ID and a board name. The device ID is the board number assigned by InstaCal. For 
example, the device ID "Dev0" indicates board number 0.

When you select a device, the first analog input channel and range that are supported by the device appear in the DAQ 
Channel and DAQ Range/Mode columns.

4. Review the channel listed in the DAQ Channel column. If the hardware supports additional channels, you can select a 
different channel number from the drop-down list. 

5. Review the range listed in the DAQ Range/Mode column. If the hardware supports additional ranges, you can select a 
different range from the drop-down list. 

You can quickly configure the remaining channels to acquire data from the same hardware by using the context menu: 
Right-click in the first column of the first row and select AutoFill All. The hardware, channels, and range information 
populate the rows for the remaining channels.

6. If you want to externally trigger the acquisition, click on the HW Trigger tab.

¡ In the Trig Device column, select the hardware to use as the trigger source. The drop-down list shows all 
Measurement Computing hardware that you can use to trigger the acquisition.

¡ In the Trig Source column, select the signal to use as the trigger source. The drop-down list shows the signals on 
the hardware that can be used use to trigger the acquisition, such as TRIGIN or AUXIN0.

¡ In the Trig Edge column, select the edge to trigger on. Choices are Positive and Negative. 

7. Click OK when you are done configuring your hardware (the OK button is disabled if the dialog contains invalid entries). 

By default, the previous hardware configuration is loaded each time you open the dialog or launch the oscilloscope. To open 
the dialog without a hardware configuration, uncheck the Load last configuration option on the Oscilloscope
Preference Settings dialog.

Context menu

You can right-click in the first column (Channeln) of the DAQ Hardware Settings dialog to display a context menu. Use the 
options on this menu to change the number of channels, configure or clear selected rows automatically, undo the last action, 
and redo the last action (when the last action was undone).

Click here for an explanation of the options on this menu.
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Saving an oscilloscope configuration file
You can save the oscilloscope hardware settings and display settings to a configuration file (*.osc). The file is saved in 
binary format in the location specified by the Configuration file path option in the Oscilloscope Preference Settings 
dialog. 

You can select from a list of pre-defined names, or enter a custom name for the configuration file. You can load each 
configuration file you save to restore the hardware and display settings on the oscilloscope.

To save current oscilloscope hardware and display settings to a configuration file:

1. Select Save Configuration from the File menu. The following menu options open.

2. Either click on the one of the pre-defined configuration file names (User0 to User7), or select Named Configuration 
to enter another name.
If you select one of the pre-defined (UserN) options, the configuration information is automatically saved to a file with 
that name (UserN.osc).

If you select the Named Configuration... option, a Save As dialog opens. Enter a name for the file (and change the 
location if you want), and then click Save to save the configuration file.

You can update the configuration file with any changes you make to the hardware settings or display settings by saving the 
configuration again with the same file name.

For information on loading a saved configuration file on the oscilloscope, go to Loading an oscilloscope configuration file.
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Loading an oscilloscope configuration file
You can load an oscilloscope configuration file (*.osc) and apply the settings to the current oscilloscope session.

When loaded, the hardware settings and display settings that are stored in the configuration file are applied to the 
oscilloscope. The name of the configuration file that you load is shown in the title bar of the oscilloscope. 

Configuration files are stored in the location specified by the Configuration file path property in the Oscilloscope
Preference Settings dialog.

To load a configuration file:

1. Select Load Configuration from the File menu. The following menu options open.

2. If the configuration file was saved using one of the predefined names (User0 to User7), you can select one of these 
from the menu.

Or, click on Named Configuration to select a configuration file from an Open dialog.

The oscilloscope updates with the hardware and display settings that are stored in the configuration file. The name of the 
configuration file appears in the title bar of the oscilloscope.

For information on saving a configuration file, go to Saving an oscilloscope configuration file.
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Setting oscilloscope preferences
You can set various options that specify where the oscilloscope stores data and configuration files, and which views are 
displayed when you run the oscilloscope.

You can set oscilloscope preferences that determine how certain options behave when the oscilloscope starts up each time 
you run it.

You set start up options using the Oscilloscope Preference Settings dialog. The dialog is shown here configured with the 
default settings for TracerDAQ Pro. 

If you are running TracerDAQ, the following options are disabled on this dialog:

n Show measurements check box

n Maximum, Minimum, Mean, Frequency, Peak-to-Peak, and RMS check boxes. 

The preference settings are stored in the system registry in HKEY_CURRENT_USER\Software\Measurement 
Computing\TracerDAQ\Preferences\Oscilloscope.

 

Preference option Description

Configuration file 
path

Sets the directory to store configuration files (*.osc). The default path is:

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Config

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Config

Click the Browse button to select a different location.

Data file path Sets the directory used to store oscilloscope history files (*.osh). The default path is:

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Data

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Data

Click the Browse button to select a different location.

Data precision in CSV 
files

Sets the digits of precision applied to csv data.

Load last 
configuration

When checked, the oscilloscope opens with the hardware configuration that was 
loaded when you last closed the oscilloscope.

When Load last configuration is not checked, the settings on the Oscilloscope 
Preference Settings dialog are applied to the oscilloscope the next time you run 
the application.

Show measurements This check box is enabled in TracerDAQ Pro only.

When checked, the Oscilloscope Measurements window automatically opens when 
you run the oscilloscope.
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Move related views When checked, the Oscilloscope Measurements window docks to the 
Oscilloscope window. When you move the Oscilloscope window, the 
Oscilloscope Measurements window moves with it. 

You can move the Oscilloscope Measurements window independently of the 
Oscilloscope window.

Show tool tips When checked, tool tips are enabled on oscilloscope dialogs.

You can toggle tool tips on and off by selecting Tool Tips from the View menu.

Maximum This check box is enabled in TracerDAQ Pro only.

When checked, the maximum value of each enabled channel shows on the 
Oscilloscope Measurements window.

You can toggle the maximum value on and off with the Oscilloscope Measurement 
Settings dialog.

Minimum This check box is enabled in TracerDAQ Pro only.

When checked, the minimum value of each enabled channel shows on the 
Oscilloscope Measurements window.

Mean This check box is enabled in TracerDAQ Pro only.

When checked, the mean value of each enabled channel shows on the Oscilloscope 
Measurements window.

Frequency This check box is enabled in TracerDAQ Pro only.

When checked, the frequency value of each enabled channel shows on the 
Oscilloscope Measurements window.

Peak to Peak This check box is enabled in TracerDAQ Pro only.

When checked, the peak to peak value of each enabled channel shows on the 
Oscilloscope Measurements window.

RMS This check box is enabled in TracerDAQ Pro only.

When checked, the root mean square value of each enabled channel shows on the 
Oscilloscope Measurements window.
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Using oscilloscope timebase controls
You can change the timebase value when acquiring or viewing data on the oscilloscope. The timebase is represented on the 
oscilloscope by each major horizontal division. There are ten major horizontal divisions. 

Timebase settings range from 1 µS to 10 seconds.
The current timebase setting appears in the upper right corner of the oscilloscope, next to the timebase hotspot controls. 

The following example shows data plotted with a timebase of 5.00ms:

n Increase the timebase to show more data points on the oscilloscope.
The following example shows the data plotted with a timebase of 10.0ms.

n Decrease the timebase to show fewer data points on the display.
The following example shows the data plotted with a timebase of 2.00ms.

Using hotspot controls to change the timebase setting
The easiest way to change the timebase setting is with the TIMEBASETIMEBASETIMEBASETIMEBASE hotspot on the oscilloscope.

Click the up/down arrows to scroll through the timebase settings. The current timebase setting appears to the left of the 
up/down arrows. The oscilloscope updates as the timebase changes. 

You can also use a mouse wheel to change the timebase setting. Scroll the mouse wheel backward to decrease the 
timebase, or forward to increase the timebase. 

Hold down the Shift key to change the timebase setting in multiples of 10. For example, when you change the timebase 
while holding down the Shift key, the value changes from 1.00ms to 10.0ms, 100ms, 1.00s, etc.

Using the Oscilloscope Display Settings dialog to change the timebase setting
You can also change the timebase setting by selecting Display Settings from the Edit menu, and changing the Timebase 
option on the Oscilloscope Display Settings dialog.
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Setting up an oscilloscope reference channel (TracerDAQ Pro only)
For any oscilloscope channel, you can capture a static instance of the signal and use it as a reference to compare with the 
channel signal as it changes.

You can only have one channel using a reference signal at a time.

To create a reference signal for a channel, do the following:

1. Right-mouse click on the reference hotspot ( ) for the channel. 

A static "shadow" signal appears with the channel signal. This is the reference channel.
2. Click on the channel plot and drag it above or below the reference channel.
3. To hide the reference channel, either:

¡ Left-mouse click on the reference hotspot ( ) for the channel. 

¡ Right-mouse click on the reference hotspot ( ) to create a reference signal for another channel. 

To show the reference signal for the channel, left-click on the reference hotspot. 

To create a new reference signal for the channel, right-click on the reference hotspot. 
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Scaling channel data on the oscilloscope
As explained in the Setting oscilloscope channel options topic, when the oscilloscope is stopped, you can set the scale mode 
for each channel by selecting the Channel Settings... option from the Edit menu to open the Oscilloscope Channel 
Settings dialog. 

When the oscilloscope is running, you can click on the scale mode hotspot to change the scale mode for each channel. 

To change scaling mode while the oscilloscope is running, do the following.

1. For each channel whose scale mode you want to change, click on the AAAA  hotspot to switch between fixed scaling and 
auto scaling.

If you set the scale mode to auto ( ), the oscilloscope calculates a scale that best fits the data.

2. If you set the scale mode to fixed ( ), you can use the up/down arrows to change the volts/division value.

When you stop the oscilloscope, your changes are reflected the next time you open the Oscilloscope Channel Settings 
dialog. 
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Saving oscilloscope data to a file
You can save the data currently displayed on the oscilloscope to an "oscilloscope history" (.osh) file, and open it later to plot 
and analyze on the oscilloscope. Oscilloscope history files only store one static window of data.

You can also save oscilloscope data to a text file (.txt or .csv), but you cannot open these types of files with the 
oscilloscope. Only save to these types of files if you want to use them with another type of application, such as a word 
processor, spreadsheet, or database.

To save the data displayed by the oscilloscope, follow these steps.
1. Select Save or Save As from the File menu.

The Save As dialog opens. By default, this dialog points to the location specified by the Data file path property in the 
Oscilloscope Preference Settings dialog.

2. In the File name text box, enter the name to save the file.
3. In the Save as type list box, select the format used to save the file (.osh, .csv, or .txt).

Only history files (.osh) can later be opened and plotted by the oscilloscope.

When saving as an ASCII text file, the numeric and list separators are based on the current Windows settings that are 
set on the computer.

The number of significant digits to display in *.csv files is set by the Data precision in CSV files option in the 
Oscilloscope Preference Settings dialog.

4. Click the Save button.

The next time you select Save..., the file you created is overwritten with the new data.
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Opening and plotting history files on the oscilloscope
You can open an oscilloscope history (.osh) in order to plot and analyze the data in the file.
When you open an oscilloscope history file, the oscilloscope enters History mode, and the DAQ status area of the 
oscilloscope shows "History". In History mode, you can change channel and display settings, the timebase value, and add 
annotations to the display. 

Oscilloscope history files only store one static window ("single sweep") of data.

To open and plot a .osh history file:
1. From the File menu, select Open....
2. From the Open dialog, select  the oscilloscope history file to open, and click Open to open the file and close the dialog.

The data in the file is plotted on the Oscilloscope window, and the scan mode changes to "History".
As with a "live" scan, you can click on the enable hotspot (EEEE ) associated with each channel to enable or disable each 
channel.

3. Select Close from the file menu to close the file and exit History mode.

You can now open another oscilloscope history file, or configure the oscilloscope to acquire and plot live data.
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Printing the oscilloscope image
You can preview and print a screen capture of the data currently on the oscilloscope.

n To preview the screen capture, select Print Preview from the File menu.

A Print preview window opens, from which you can zoom in on the image and then print it.

 Click on this icon to zoom in (150% to 500%) or zoom out (10% to 75%) on the oscilloscope capture.

 Click on this icon to print the oscilloscope capture to your default printer. The screen capture always prints in a 
landscape orientation, and fits to the size of your paper and not to the current zoom setting.

n When you are done previewing and printing, click on the Close button.

n To print the image without previewing, select Print from the File menu.

A Print dialog opens. Review the settings on the dialog and click OK to print the image to your default printer.

Page 69 of 106



Capturing an image of the oscilloscope (TracerDAQ Pro only)
You can capture an image of the oscilloscope to the Windows clipboard by selecting Copy to Clipboard from the Edit 
menu.

The image on the oscilloscope is copied to the clipboard and remains there until you paste the image or select the copy 
option again.

You can paste the image into any application that supports bitmap (*.bmp) images.
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Clearing data from the oscilloscope
Acquired data is stored in a memory buffer until it is saved or cleared. 

1. If you want to save the data to a file before you clear it, select Save from the File menu.
2. To clear data from the memory buffer and the oscilloscope, select Clear Display from the Edit menu, and click Yes on 

the dialog that prompts you for confirmation.

All data is cleared from the oscilloscope and from the memory buffer.
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Setting oscilloscope trigger options
You can trigger the oscilloscope to acquire data using an internal software trigger. You can also set up an external source to 
trigger the oscilloscope.
When setting up an internal trigger, you set the channel to use as the trigger source, the trigger mode, and slope of the 
signal, and the value to monitor. 

When setting up an external trigger, you set the hardware, the trigger channel, and the edge used to trigger on.

You can set trigger options while the oscilloscope is stopped using the Trigger Settings dialog. You can also set internal 
channel settings while oscilloscope is running or stopped using the trigger hotspots on the oscilloscope.

Setting up an internal trigger while the oscilloscope is running (Trigger hotspots)
The oscilloscope includes hotspots you can use to set and change internal trigger settings while the oscilloscope is running. 

n To change the trigger channel's trigger mode, click on the channel's trigger mode hotspot until it is set to the trigger 
mode that you want:

 - The trigger channel is in Normal mode. 

 - The trigger channel is in Auto mode. 

 - The trigger channel is in Single mode. 

When you change the trigger mode, the trigger status area shows the new setting. 

n To change the trigger channel's trigger slope, click on the channel's trigger slope hotspot to switch between Rising and 
Falling.

 - Sets the trigger to be detected on a Rising slope. 

 - Sets the trigger to be detected on a Falling slope. 

When the trigger condition is met, the status changes to Trig'dTrig'dTrig'dTrig'd while data is acquired.

Setting up a trigger while the oscilloscope is stopped (Trigger Settings dialog)
To set up a trigger while the oscilloscope is stopped, select Trigger Settings... from the Edit menu to open the Trigger
Settings dialog. 

When you select a trigger mode and run the oscilloscope, the trigger status area shows the selected trigger mode. 

When the trigger condition is met, the status changes to Trig'dTrig'dTrig'dTrig'd while data is acquired.

Setting up an internal trigger

To set up an internal trigger, do the following:
1. From the Trigger source drop-down list, select the channel to monitor for the trigger value. 

2. From the Trigger mode drop-down list, select Auto, Normal, or Single.  

¡ Auto: If no trigger occurs, the oscilloscope automatically starts after a short amount of time (based on the 
TIMEBASETIMEBASETIMEBASETIMEBASE setting).

¡ Normal: The oscilloscope starts plotting data when the signal reaches the Trigger value.

¡ Single - The oscilloscope waits for a trigger, graphs a single sweep of data, and then stops. This mode is useful for 
capturing signals that are not periodic and that occur only once.
The next two options — trigger slope and trigger level — define the basic trigger point and determine how the plot 
displays on the oscilloscope.

3. From the Trigger slope drop-down list, select whether the trigger point is on the rising edge or the falling edge of a 
signal. Choices are Rising and Falling. 

A rising edge is a positive slope, and a falling edge is a negative slope.
4. In the Trigger level numeric control, enter the value to generate the trigger.
5. Click OK when you are done setting the trigger options.

Setting up an external trigger

If you select an External trigger source, you can select the device used as the source of the trigger signal, and the edge on 
which to detect the trigger.

You cannot set up an external trigger source  if you are acquiring data from multiple devices.
1. From the Trigger Select area, select External. This option is disabled if you are acquiring data from multiple devices. 

The Trigger mode hotspot changes to  when you set up an external trigger source.
2. Click on the Setup hardware trigger button ( ) to open the DAQ Hardware Settings dialog.
3. Click on the HW Trigger tab. 
4. In the Trig Device column, select the hardware to use as the trigger source. The drop-down list shows all 

Measurement Computing hardware that you can use to trigger the acquisition.
5. In the Trig Source column, select the signal to use as the trigger source. The drop-down list shows the signals on the 

hardware that can be used to trigger the acquisition, such as TRIGIN or AUXIN0.
6. In the Trig Edge column, select the edge to trigger on (Positive or Negative). 
7. Click OK when you are done configuring the external trigger source. 
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Setting oscilloscope marker options
The oscilloscope has two markers that you can move to any horizontal or vertical location on the oscilloscope to view the 
values of specific data points. The markers are identified on the oscilloscope as MK0 and MK1.

You can set the color of each marker, and whether or not the marker is visible on the oscilloscope. You can also set the 
orientation to vertical (default) or horizontal.

When you click on a marker, its position appears at the top of the oscilloscope, and its values—including the delta value, 
which is the difference between the two marker values—show on the right side of the oscilloscope. Click here to see an 
example. You can set the number of seconds that these values remain on the oscilloscope.

You can set marker options while the oscilloscope is stopped with the Oscilloscope Display Settings dialog. You can also 
set marker options while the oscilloscope is running or stopped using the SETSETSETSET  hotspot dialog. 

Setting marker options while the oscilloscope is running (SETSETSETSET  hotspot) 
You can click on the SETSETSETSET  hotspot to change marker options without opening the Oscilloscope Display Settings dialog. Do 
the following:
1. Click the SETSETSETSET  hotspot on the oscilloscope. 

2. Click on the MarkersMarkersMarkersMarkers tab to set these marker options:

n MarkerMarkerMarkerMarker: Click the up/down arrows to select either Marker0 (MK0MK0MK0MK0) and marker1 (MK1MK1MK1MK1).

n EnabledEnabledEnabledEnabled: Click the up/down arrows to select either TrueTrueTrueTrue (marker is visible) or FalseFalseFalseFalse (marker is not visible).

n ColorColorColorColor: Click on the color block to open a Color dialog and select a color for the marker.

n OrientationOrientationOrientationOrientation: Click the up/down arrows and select either VerticalVerticalVerticalVertical or HorizontalHorizontalHorizontalHorizontal.

3. To change the amount of time that the marker information remains on the oscilloscope, click on the DisplayDisplayDisplayDisplay tab.

SelectTimeSelectTimeSelectTimeSelectTime: click the up/down arrows to change the time using 1.0 second increments. Tip: Hold down the Ctrl key 
to change the time using 0.5 second increments.

4. Click ExitExitExitExit when you are done setting marker options.

Setting marker options while the oscilloscope is stopped (Oscilloscope Display Settings dialog)
1. Stop the oscilloscope if it is running.
2. Select Display Settings from the Edit menu to open the Display Settings dialog.
3. Click on the Markers tab.
4. Select a marker (Marker0 or Marker1) from the list.

Press the Ctrl key to select both markers. The options you set in the Marker Settings frame apply to the selected 
marker(s).

5. Check the Enabled checkbox to show the selected marker(s) on the oscilloscope, or uncheck the checkbox to hide the 
selected marker(s).

6. Click on the Color button to change the color of the selected marker(s).
7. Set the orientation to either Vertical or Horizontal.
8. Click on the General tab to set the number of seconds that marker values remain on the oscilloscope.
9. Click the up/down arrows to change the Selection time option using 0.5 second increments. 

10. Click OK when you are done setting marker options.
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Setting oscilloscope display options
You can set display options to control the general appearance and content of the oscilloscope. For example:

n you can set the length of time that marker position data is visible on the oscilloscope

n you can set the value per major horizontal division on the oscilloscope

n you can enable/disable hotspots

n you can apply a custom color scheme to the oscilloscope foreground and background

You can set these display options while the oscilloscope is stopped using the Oscilloscope Display Settings dialog. You 
can also set display settings while the oscilloscope is running or stopped using the SETSETSETSET  hotspot dialog. 

Setting display properties while the oscilloscope is running (SETSETSETSET  hotspot) 
You can click the SETSETSETSET  hotspot and set display options while the oscilloscope is running. Do the following:  

1. Click the SETSETSETSET  hotspot on the oscilloscope. 

2. Click on the DisplayDisplayDisplayDisplay tab to access display properties:

¡ ContrastContrastContrastContrast: Sets the color of the lane background. Click the up/down arrows to select a value from 0.0 to 1.0. This 
value is used to blend the foreground and background colors together. The resulting color is used as the lane 
background color. 

¡ ColColColCol Scheme Scheme Scheme Scheme: C lick the up/down arrows to toggle between predefined color schemes applied to the display 
foreground, background, channel markers, and data markers.

¡ Fore ColorFore ColorFore ColorFore Color: Click on the color block and select the color of the display foreground. 

¡ Back ColorBack ColorBack ColorBack Color: Click on the color block and select the color of the display background. 

¡ SelectTimeSelectTimeSelectTimeSelectTime: Click the up/down arrows to select the time in seconds that marker and timebase values remain on 
the oscilloscope. 

3. Click ExitExitExitExit when you are done setting display properties.

Setting display options while the oscilloscope is stopped (Oscilloscope Display Settings dialog)
1. Stop the oscilloscope if it is running.
2. Select Display Settings from the Edit menu to open the Oscilloscope Display Settings dialog. 

Use the General tab to set display options.

¡ Selection time: Enter the number of seconds that marker position values and timebase values appear on the 
oscilloscope.

¡ Timebase: Set the value per major horizontal division on the oscilloscope. For more information, go to the Using
oscilloscope timebase controls topic.

¡ Enable hotspot: Check in this checkbox to enable hotspots on the oscilloscope. When unchecked, hotspots are 
disabled. For more information on oscilloscope hotspots, go to the Hotspot on the oscilloscope topic.

¡ Color Scheme: Select a color scheme from a list of predefined values. The color scheme is applied to the 
oscilloscope background and foreground. You can also select the colors yourself from the options below. When you 
select the colors, the Color Scheme option is set to Custom.

¡ Contrast: Select a value from 0.0 to 1.0. This value is used to blend the foreground and background colors together 
to create the background color of the oscilloscope.

¡ Background Color: Click the Background Color button and select the color of the oscilloscope background.

¡ Foreground Color: Click the Foreground Color button and select the color of the oscilloscope foreground.

3. Click OK when you are done setting display options.
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Setting oscilloscope channel options
You can acquire and plot up to two channels on the oscilloscope using TracerDAQ. You can acquire and plot up to four 
channels on the oscilloscope using TracerDAQ Pro. 

You can specify the number of channels, enter a name and unit for each channel, and change the line style and color of the 
plot line. You can also disable channel data from appearing on the display, and enable scaling for each channel.

You can set these channel options while the oscilloscope is stopped using the Oscilloscope Channel Settings dialog. You 
can also set channel settings while the oscilloscope is running or stopped using the SETSETSETSET  hotspot dialog or Channel x 
hotspot.

Setting channel options while the oscilloscope is running (CHANNELCHANNELCHANNELCHANNELXXXX hotspot)

You can click on one of the CHANNELCHANNELCHANNELCHANNEL hotspots to change channel options while the oscilloscope is running. 

1. Click the CHANNELCHANNELCHANNELCHANNELXXXX hotspot for the channel whose options you want to change.
A dialog opens with the SETSETSETSET  hotspot's Chan'sChan'sChan'sChan's tab active. You can change one or more of these options. 

¡ ChannelChannelChannelChannel: Click the up/down arrows to change the channel (CH0 - CHn) whose options you want to set. 

¡ NameNameNameName: Click on EDEDEDED (edit) to change the name of the selected channel.

¡ ColorColorColorColor: Click on the color block to open a standard Color dialog and select a color for the channel's plot line.

¡ Plot StylePlot StylePlot StylePlot Style: Click the up/down arrows to select a line style. Choices are Solid, Dashed or Dots used to plot the 
data.

¡ Trig ModeTrig ModeTrig ModeTrig Mode (TracerDAQ Pro only): Click the up/down arrows to select either Auto, Normal, or Single for the 
internal trigger mode.

¡ ProbeProbeProbeProbe: Click the up/down arrows to select either X1, X10, X100, and X1000 for the multiplier to apply to each 
channel value.

2. Click ExitExitExitExit when you are done setting channel options.

Setting channel options while the oscilloscope is stopped (Oscilloscope Channel Settings dialog)
1. Stop the oscilloscope if it is running.
2. From the Edit menu, select Channel Settings to open the Oscilloscope Channel Settings dialog.
3. In the Number of channels text box, enter the number of channels to plot on the oscilloscope.

The list of channels dynamically updates according to the number you enter. 

TracerDAQ supports two channels. TracerDAQ Pro supports four channels.

Note: If you set the number of channels to a value greater than the number of channels configured on the DAQ 
Hardware Settings dialog, you must configure the new channel(s) before you can run the oscilloscope. If you attempt 
to run the oscilloscope without configuring the new channel(s), a DAQ input error dialog opens.

4. In the channel list, select a channel number and set its options using the options on the Channel Settings frame. 

Hold down the Ctrl key to select more than one channel.

¡ Channel Enabled: Click in the check box to show channel data on the oscilloscope. When unchecked, data is still 
acquired but is not visible on the oscilloscope.

¡ Name: Enter a unique name for the channel. Only one channel can be selected to enter a name. The channel name 
appears in the Oscilloscope Measurements window.

¡ Plot style: Select the line style (Solid, Dashed, or Dots) used to plot the data.

¡ Color: Click this button to open a Color dialog and select the color of the plot line. 

¡ Scale: Select the vertical scale applied to the channel data.

¡ Probe: Select the multiplier applied to each channel value. Choose from X1, X10, X100, and X1000.

5. Click on the OK button when you are done setting channel options.

When running TracerDAQ Pro, you can set up a math channel on the oscilloscope. Go to the topic Setting Math channel
options (TracerDAQ Pro only) for more information.
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Setting oscilloscope math channel options (TracerDAQ Pro only)

Setting math channel options while the oscilloscope is running (SETSETSETSET  hotspot) 

You can click on the SETSETSETSET  hotspot to change math channel options without opening the Oscilloscope Channel Settings 
dialog. 

Do the following:

1. Click the SETSETSETSET  hotspot on the oscilloscope. 

2. Click on the MathMathMathMath tab to access channel options:

¡ FunctionFunctionFunctionFunction: Click the up/down arrows to select the math function. If you select a function for which you have not 
configured a channel, the channel is treated as "0" in the function. For example, if you configure CH0 and CH1 to plot 
data, and select the math function "CH3 Invert", the oscilloscope calculates the inverse of 0, and shows a flat line on 
the oscilloscope.

¡ ColorColorColorColor: Click on the color block to open a standard Color dialog and select a color for the math line.

¡ Plot StylePlot StylePlot StylePlot Style: Click the up/down arrows to select a line style. Choices are Solid, Dashed or Dots used to plot the 
math channel.

3. Click Exit when you are done setting channel options.

The math channel updates on the oscilloscope according to the options you set. You can turn the math channel on and off by 
clicking on the MATMATMATMAT  hotspot on the oscilloscope. 

Setting math channel options while the oscilloscope is stopped (Oscilloscope Channel Settings 
dialog)
You can show or hide a math channel on the oscilloscope. You select the math function used to calculate the math channel. 
You can also set the color and style of the line used to plot the channel. 

Do the following:

1. Stop the oscilloscope if it is running.
2. Select Channel Settings from the Edit menu to open the Oscilloscope Channel Settings dialog.
3. Click on the Math Channel tab to set math channel options.
4. Check the Enabled check box to show the math channel on the oscilloscope.
5. From the Plot style list box, select the style of the plot line. Choose from Solid, Dashed, or Dots.
6. Click the Color button and set the color of the plot line.
7. From the Math Function list, set the function used to calculate the math channel. Select from:

The math channel updates on the oscilloscope according to the function you select. The math channel is labeled MAT on 
the oscilloscope.
If you select a function for which you have not configured a channel, the channel is treated as "0" in the function. For 
example, if you configure CH0 and CH1 to plot data, and select the math function "CH3Invert", the oscilloscope 
calculates the inverse of 0, and shows a flat line on the oscilloscope.

8. Click OK when you are done setting math channel options.

The example below shows a math channel on the oscilloscope. The math channel was calculated using the function CH0 - 
CH1. 
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When you add a math channel, the selected function appears at the top of the oscilloscope. You can set the number of 
seconds that the function name is visible.

You can show and hide the math channel on the oscilloscope by clicking on the MATMATMATMAT  hotspot. 
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Showing measurements on the Oscilloscope Measurements window (TracerDAQ 
Pro only)
When you run TracerDAQ Pro, the Oscilloscope Measurements window appears by default with the Oscilloscope 
window. The Oscilloscope Measurements window does not appear when you are running TracerDAQ.

The Oscilloscope Measurements window lists the values for each channel you plot on the oscilloscope. You can choose which 
measurement values to show on the window. Choices are:

n Maximum

n Minimum

n Mean

n Frequency

n Peak-to-Peak 

n RMS (root mean square)

The measurement values automatically update for each channel as the oscilloscope acquires data. 

To select the measurement values to show on the Oscilloscope Measurements window:

1. Select Preferences from the File menu to open the Oscilloscope Preference Settings dialog. You select the 
measurement values to show from the Measurements pane.

2. Click in the check box for each measurement value you want to list on the Oscilloscope Measurements window. The 
value of each selected measurement appears on the window for each channel on the oscilloscope.

¡ Maximum: check this box to show the maximum value of each channel.

¡ Minimum: check this box to show the minimum value of each channel.

¡ Mean: check this box to show the mean value of each channel.

¡ Frequency: check this box to show the frequency of each channel.

¡ Peak to peak: check this box to show the peak to peak value of each channel.

¡ RMS: check this box to show the root mean square value of each channel.

When unchecked, the measurement value does not appear on the Oscilloscope Measurements window.

3. Click OK when you are done.

Showing and hiding the Oscilloscope Measurements Window

You can turn the Oscilloscope Measurements Window on and off by selecting Measurements from the View menu. When 
Measurements is checked, the Oscilloscope Measurements window is visible.
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Introducing the function generator
TracerDAQ's function generator is a virtual application used to generate analog waveforms from supported Measurement 
Computing DAQ hardware with analog outputs.

The function generator calculates the maximum throughput rate of your Measurement Computing DAQ hardware based on:

n the device’s maximum sampling rate 

n the device’s packet size requirements for continuous mode 

n the waveform frequency you want

The number of samples within one cycle of the waveform frequency you want must be an integer multiple of the device’s 
packet size.
When you generate waveforms from signals on multiple devices, the function generator uses the continuous throughput rate 
of the slowest device.

For example, if the device’s maximum continuous sampling rate is 100,000 Hz, its packet size is 32, and you want a 
waveform frequency of 100 Hz, TracerDAQ does the following:

1. Calculates initial number of samples per cycle (maximum continuous rate/frequency you want)

100000/100 = 1000

 
2. Calculates the number of packets per cycle (samples per cycle/packet size)

1000/32 = 31.2

 
3. Truncates the packets per cycle result and calculates the actual number of samples per cycle (number of packets per 

cycle x packet size)

31 x 32 = 992 (samples per cycle)

 
3. Calculate the scan rate (number of samples per cycle x desired waveform frequency)

992 x 100 = 99,200 Hz

You select the analog output channel to output. The function generator displays the sample waveform, samples per cycle, 
internal scan rate, and base frequency of the signal. Hotspot controls on the function generator let you select an output 
channel and change properties of the output signal.

With the function generator, you can perform the following tasks:

n Generate waveforms for up to 16 analog output channels on multiple Measurement Computing DAQ devices with 
TracerDAQ Pro. Generate a sine wave for one analog output channel on an Measurement Computing DAQ device with 
TracerDAQ.

n Specify the waveform pattern to output (TracerDAQ Pro only)

n Perform linear and logarithmic sweeps (TracerDAQ Pro only)

n Change the phase, duty cycle, rate multiplier and gate ratio of the waveform (TracerDAQ Pro only)

n Generate arbitrary signals from data stored in a text file (.csv or .txt)

n Change the amplitude and DC level of the waveform

n Change the base frequency of the signal

n Save hardware configurations for future use

n Customize the appearance of the function generator

Function generator Quick Start
For a quick, hands-on exercise that shows you how to generate a waveform signal on the function generator, click on the 
Quick Start button below.

A Measurement Computing device with analog output channels is required to perform this quick start exercise.
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Overview of the function generator environment
When you run the function generator application, the main Function Generator window opens. Components on the function 
generator are identified below. An asterisk (*) after the component name indicates that the component is also a hotspot.

n The menu bar provides access to dialogs that you use to perform all function generator operations.

For more information about the menu bar, go to the Overview of the function generator menu bar topic.

n The active operation state is shown at the top of the function generator ("Running" or "Stopped").

Hotspot controls (identified with an asterisk*) let you change settings right on the function generator without opening a 
dialog:

¡ Start and stop waveform generation

¡ Select the channel number to output

¡ Change signal options

¡ Select the base frequency of the signal

¡ Enable or disable the signal from appearing on the function generator

¡ Enable sweep mode (TracerDAQ Pro only)

For more information about function generator hotspots, go to the Hotspots on the function generator topic.

n The DAQ Rate lists internal scan rate of the hardware.

The function generator supports the maximum throughput rate of your Measurement Computing DAQ hardware. When 
using multiple devices, the function generator uses the throughput rate of the slowest device.

n The status bar shows the output status ("Running" or "Idle"), and lists invalid configuration messages and error 
conditions.

n The waveform preview area shows the sample waveform according to the options you set.

How the function generator outputs data

The function generator uses an output scan function to output data. If the hardware does not have hardware timing support, 
the function generator uses a system timer to repeatedly call the output scan function on the device to update the buffer 
with the most recent data to output.

When sweep mode is disabled, the function generator runs the hardware at or near its maximum scan rate. When you 
generate signals from multiple devices, the function generator uses the maximum rate of the slowest device.

When sweep mode is enabled, the function generator runs the hardware at or near its maximum scan rate. 

Error handling

If an error occurs, the function generator stops the signal output, and displays the error message on its status bar. A dialog 
of the error message also opens. An example is shown here.
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Overview of the function generator menu bar
The function generator menu bar options are explained in the following table.

 

Menu item Explanation

File Includes options you can use to:
n start a new function generator session
n import arbitrary data files stored in a text file (.csv or .txt)
n save or load a configuration file
n configure start up preference settings

Click on the following button for instructions on how to perform these tasks.

Edit Includes options you can use to:
n configuring your Measurement Computing hardware
n change function generator display options
n change function generator channel options

Click on the following button for instructions on how to perform these tasks. 

View Includes an option to enable or disable pop up tool tips from appearing on function generator 
dialogs.

Action Includes options you can use to start or stop signal output

Help Includes options you can use to:
n open the TracerDAQ online help file
n view TracerDAQ version and contact information
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Hotspots on the function generator
The Function Generator window has several hotspots. A hotspot is an interactive area on the function generator that lets 
you change settings while the function generator is running. 

All hotspots have corresponding dialogs that you access through the function generator menu bar to perform the same 
action.

Hotspot controls on the function generator are identified below. 

 
 

 
   

Hotspot Explanation

Starts the signal output.

Stops the signal output.

Channel number selector. Click the up/down arrows to select the channel to 
apply the channel settings.

Channel enable/disable. Click the "E" to enable or disable the output of the 
selected channel. 

When enabled, the output signal appears on the function generator.

When disabled ( ), the signal preview appears as a horizontal 
line.

Options used to generate the output signal.

Click the up/down arrows to change the value. 

The DC Level, Phase, Multiplier and Gate Ratio options are only enabled 
when using TracerDAQ Pro.

Sets the base frequency selector. The range is based on the frequency of 
the installed device.

Click the up/down arrows to change the frequency of the signal.

Sets sweep mode to Linear, Exponential, or Off. 
Additional settings appear when sweep mode is set to Linear or Exponential, 
as shown below:

Sets the number of seconds to sweep the frequency. This hotspot appears 
when sweep mode is set to Linear or Exponential.

The initial frequency (Hz) of the signal. This hotspot appears when sweep 
mode is set to Linear or Exponential.
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When the hotspot is an up/down arrow, you can change the value by clicking on the arrows or by scrolling a mouse wheel 
forward or backward on the arrows. 

When the option is a numeric value, you can also click directly on the value to open a text box and enter a new number. 
Click here for an example.

  

 

 

 
 

   
 

 

  
 

 

 

 
 

 
 

 

 
 
 

 
 

 
 

The final frequency (Hz) of the signal. This hotspot appears when sweep 
mode is set to Linear or Exponential.
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Quick Start - Generating waveforms with the function generator 
As stated in the introduction, you can generate waveforms with TracerDAQ "soon after you install your Measurement 
Computing DAQ hardware."

You can get a feel for what TracerDAQ can do even sooner by generating a waveform with the function generator.

Note: A Measurement Computing DAQ device with analog output channels is required to perform this exercise.

To generate a waveform with the function generator:
1. Make sure you have completed the steps in the "Running InstaCal and adding your hardware" section of the DAQ 

Software Quick Start.
2. Run TracerDAQ by selecting Programs ���� Measurement Computing ���� TracerDAQ ���� TracerDAQ from the Start 

menu.
3. From the TracerDAQ dialog, select Function Generator, and click on Run. The function generator application opens.
4. Select New... from the File menu. The DAQ Hardware Settings dialog opens.
5. From the first row of the DAQ Device column, select your hardware from the DAQ Device column list box.

The drop-down list shows the device ID and device name for all boards with analog outputs that were configured by 
InstaCal. When you select a device, the first channel and range that are supported by the device appear in the DAQ
Channel and DAQ Range/Mode columns.

Click here to see an example of a channel configured for analog output.
6. Click on the OK button to save the setting and close the dialog. The waveform is output to the function generator.

7. Click the Run button ( ) on the function generator to start an output scan that sends output data to all configured 
channels.

8. To stop the scan, click on the Stop button ( ).

That's all there is to it! The function generator provides many options that let you change the properties of the waveform, 
DAQ hardware, and the function generator display. Refer to the topics in the Table of Contents for more information.
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Configuring DAQ hardware for the function generator
You can generate waveforms using Measurement Computing data acquisition hardware that support analog outputs.

You set up your hardware configuration with the DAQ Hardware Settings dialog. Use this dialog to configure the 
hardware, channels, and range used to generate waveforms.

The first time you run the function generator, the dialog opens without any configuration information. Dialog tool tips advise 
you of the action to take.

Note: The function generator must be stopped for you to configure DAQ hardware. You cannot configure hardware when 
the function generator is running or paused.

DAQ hardware settings

To configure your DAQ hardware:

1. Stop the function generator if it is running.
2. Select DAQ Hardware Settings from the Edit menu (or select File > New). The DAQ Hardware Settings dialog 

opens.

3. In the DAQ Device column, select a hardware device from the drop-down list. 

The drop-down list shows all boards with analog output channels that are configured by InstaCal and detected by the 
Universal Library. The list includes a device ID and a board name. The device ID is the board number assigned by 
InstaCal. For example, the device ID "Dev0" indicates board number 0.

When you select a device, the first analog output channel and range that are supported by the device appear in the 
DAQ Channel and DAQ Range/Mode columns.

4. Review the channel listed in the DAQ Channel column. If the hardware supports additional analog output channels, you 
can select a different channel number from the drop-down list. 

5. Review the range listed in the DAQ Range/Mode column. If the hardware supports additional ranges, you can select a 
different range from the drop-down list. 

6. Click OK when you are done configuring your hardware. 

The OK button is disabled if the dialog contains invalid entries. 

Note: By default, the previous hardware configuration is loaded each time you open the dialog or launch the function 
generator. To open the dialog without a hardware configuration, uncheck the Load last configuration option on the 
Function Generator Preference Settings dialog.

Context menu

You can right-click in the first column (Channeln) of the DAQ Hardware Settings dialog to display a context menu. Use the 
options on this menu to change the number of channels, configure or clear selected rows automatically, undo the last action, 
and redo the last action (when the last action was undone).

Click here for an explanation of the options on this menu.

Note: The dialog opens by default with one channel to configure. To change the number of channels, right-
click in the first column and select Number of Channels. Enter the desired number of channels in the 
dialog that opens, and click OK.

Note: You can quickly configure the remaining channels to generate waveforms using the same hardware 
by using the context menu: Right-click in the first column of the first row and select Auto-fill All. The 
hardware, channels, and range information populate the rows for the remaining channels.
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Saving a function generator configuration file
You can save the function generator hardware settings and display settings to a configuration file (*.fgc). The file is saved in 
binary format in the location specified by the Configuration file path option in the Function Generator Preference
Settings dialog. 

You can specify the name with which to save the configuration file, or select from a list of pre-defined names. You can load 
the configuration file to restore the hardware and display settings on the function generator.

To save current function generator hardware and display settings to a configuration file:

1. Select Save Configuration from the File menu. The following menu options open.

2. Click on the one of the pre-defined file names (User0 to User7) with which to save the file, or select Named 
Configuration to enter another name.
If you select one of the pre-defined (UserN) options, the configuration information is automatically saved to a file with 
that name (UserN.fgc)

If you select the Named Configuration... option, a Save As dialog opens. Enter a name for the file (and change the 
location if you want), and then click Save to save the configuration file.

You can update the configuration file with any changes you make to the hardware settings or display settings by saving the 
configuration again with the same file name.

For information on loading a saved configuration file on the function generator, go to Loading a function generator
configuration file.
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Loading a function generator configuration file
You can load a configuration file that was previous saved with the function generator (*.fgc), and apply the settings to the 
current function generator session.

When loaded, the hardware settings and display settings that are stored in the configuration file are applied to the function 
generator. The name of the configuration file that you load is shown in the title bar of the function generator.

Configuration files are stored in the location specified by the Configuration file path property in the Function Generator
Preference Settings dialog.

To load a configuration file:

1. Select Load Configuration from the File menu. The following menu options open.

When a configuration is saved using one of the predefined names (User0 to User7), those configuration names are 
selectable here.

2. Select the configuration file you want to load (User0 to User7, if enabled), or click on Named Configuration to select a 
configuration with a different name.  

If you click on Named Configuration, an Open dialog appears. Select the configuration file you want to load and click on 
the Open button.

The function generator updates with the hardware and display settings that are stored in the configuration file. The name of 
the configuration file appears in the title bar of the function generator. An example is shown here:

For information on saving a configuration file, go to Saving a function generator configuration file.
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Importing arbitrary data files for output on the function generator
You can import arbitrary waveform data that is stored in a text file (.txt or .csv).

TracerDAQ can open a file size containing up to 32K samples. TracerDAQ Pro can open a file size containing up to 1M 
samples.

To import arbitrary signal data:

1. Select Open from the File menu. The Arbitrary Waveform dialog opens. 
2. Click on the Browse button next to the Source file text box and navigate to the directory containing the csv or text 

file to open. By default, this dialog points to the location specified by the Arbitrary waveform path property on the 
Function Generator Preference Settings dialog.

3. Select a .csv or .txt file and click Open.

A preview of the selected file's contents appears in a File Preview window. Use this window to:

¡ Identify the number of header rows, if any, included in the text file.

¡ Review the column data contained in the file.

¡ Note the delimiter character used to separate data in the file. You select the delimiter character using the Specify 
a delimiter list box; it is not set automatically.

Note that the preview window does not list all of the data in the file.

The example below shows a file containing eight lines of header information and two columns of data separated by a 
comma (CHANNEL0 and CHANNEL1).

4. Click on the line that you want the strip chart to start reading from, or enter the number in the numeric up/down 
control. When you click on a line, the numeric up/down control automatically updates with the number of the row you 
select.

5. Use the Specify a delimiter list box to select the delimiter used to separate data in the selected file. Select from 
Comma, Space, Tab, and Semicolon.

6. Click on the OK button.

The File Preview window closes. The column data contained in the selected file appears in the Available Channels 
area of the Arbitrary Waveform dialog. Click here for an example.

7. Select the data column(s) to plot from the Available Channels area, and click the right arrow button to move the 
highlighted column(s) over to the Selected Channels list. The double arrow button moves all of the channels in the 
direction of the arrow.

At least one column must be in the Selected Channels list before the OK button is enabled.
8. Click OK to close the Arbitrary Waveform dialog.

Note: If the number of columns selected to output to the function generator is greater than the number of channels 
configured on the DAQ Hardware Settings dialog, a message box opens. Click Yes to open the DAQ Hardware 
Settings dialog to configure the channel(s).

The waveform data that is read from the file is treated as a pattern that is generated at the frequency set by the base 
frequency option (BASE BASE BASE BASE FRQFRQFRQFRQ). In other words, the pattern is treated as one cycle of data.
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The example below shows a column of data output to the function generator.

If the function generator cannot convert data in the text file

If the function generator is unable to convert the data read from the text file, a dialog opens with the line number and value 
that failed the conversion. For example, if the first line in the File Preview window above is selected as the first line to 
start reading, the following error message opens:

Click on the OK button to close the dialog.

n If the data value is in one of the columns, remove the column from the Selected Channels list.

n If the data value is part of the header information, change the number of the row to start reading from.

n Verify that you selected the correct delimiter that is used to separate data in the file.

Once you have updated and/or verified the line to start from, the delimiter character, and the column data to output, try to 
open the file again using the above procedure.
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Setting function generator preferences
You can set the location to store waveform data and configuration files, whether to load the most recently used 
configuration file at start-up, and whether to show tool tips on function generator dialogs.  

You set start up options using the Function Generator Preference Settings dialog (File > Preferences menu). The dialog 
is shown here configured with its default settings.

The preference settings are stored in the system registry in HKEY_CURRENT_USER\Software\Measurement 
Computing\TracerDAQ\Preferences\FunctionGenerator.

 

Menu item Description

Configuration file path Sets the directory to store configuration files (*.fgc). The default path is:

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Config

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Config

Click the Browse button to select a different location.

Arbitrary waveform 
path

Sets the directory used to store function generator data files (*.csv or *.txt). The 
default path is:

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Data

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Data

Click the Browse button to select a different location.

Load last configuration When checked, the function generator opens with the hardware configuration that 
was loaded when you last closed the function generator.

When Load last configuration is not checked, the settings on the Function Generator 
Preference Settings dialog are applied to the function generator the next time you 
run the application.

Show tool tips

 

When checked, tool tips are enabled on function generator dialogs.

You can toggle tool tips on and off by selecting Tool Tips from the View menu.
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Setting function generator channel options
You can generate up to 16 waveforms on the function generator using TracerDAQ Pro, and one waveform using TracerDAQ. 
You specify the analog output channel number and the frequency of the signal (Hz). With TracerDAQ Pro, you can also 
specify the waveform pattern to generate. 

You can set the following channel options:

n the number of analog output channels

n enable or disable the output of the selected channel

n the channel name

n the waveform pattern to generate (TracerDAQ Pro)

n the waveform options

n the base frequency of the signal (Hz)

n linear or exponential sweeps (TracerDAQ Pro only)

The signal that is generated by the output channel appears on the function generator.

You can set these channel options while the function generator is stopped using the Function Generator Channel 
Settings dialog. You can also set these channel settings while function generator is running or stopped using the hotspots 
on the function generator.

Setting channel options while the function generator is running (hotspots)

You can set channel options using the function generator's hotspot controls without opening the Function Generator 
Channel Settings dialog:

n CHANNELCHANNELCHANNELCHANNEL: Click the up and down arrows to select the channel.

n EEEE : Click to enable or disable the output of the selected channel on the function generator. 

n PATTERNPATTERNPATTERNPATTERN: Click the up and down arrows and select the waveform pattern to generate for the selected channel. With 
TracerDAQ, this option is set to Sine.

n AMPLITUDEAMPLITUDEAMPLITUDEAMPLITUDE: Click the up and down arrows and select the amplitude of the waveform. The amplitude range is based on 
the range selected for the channel in the DAQ Hardware Settings dialog. Amplitude is disabled when the pattern type is 
set to Flat.

n DC LEVELDC LEVELDC LEVELDC LEVEL: Click the up and down arrows and select the DC level of the waveform.

n PHASEPHASEPHASEPHASE: Click the up and down arrows and select the phase (in degrees) of the waveform. Phase is disabled when the 
pattern type is set to Random or Flat. This option is enabled in TracerDAQ Pro only.

n DUTY CYCLEDUTY CYCLEDUTY CYCLEDUTY CYCLE: Click the up and down arrows and select the duty cycle (up to 100 percent) of the waveform. Duty Cycle 
is disabled when the pattern type is set to Flat, Ramp, Random, or Arbitrary. This option is enabled in TracerDAQ Pro 
only.

n MULTIPLIERMULTIPLIERMULTIPLIERMULTIPLIER: Click the up and down arrows and select the multiplier of the waveform. Values are X1 through X10. 
Multiplier is disabled when the pattern type is set to Random or Flat. This option is enabled in TracerDAQ Pro only.

n GATE RATIOGATE RATIOGATE RATIOGATE RATIO: Click the up and down arrows and select the percent gate ratio (up to 100) of the waveform. This option 
is enabled in TracerDAQ Pro only.

n SWEEP MODESWEEP MODESWEEP MODESWEEP MODE: Click the up and down arrows to set sweep mode to Linear, Exponential, or Off.

n BASE BASE BASE BASE FRQFRQFRQFRQ: Click the up and down arrows to change the base frequency of the signal (in Hz). 

You can set the base frequency to a value between 0.1 Hz up to the maximum output rate of the hardware divided by 
100.

Setting channel options while the function generator is stopped (Function Generator Channel 
Settings dialog)
1. Stop the function generator if it is running.
2. Select Channel Settings from the Edit menu to open the Function Generator Channel Settings dialog. Use the 

Channel tab to set channel options.
3. In the Number of channels text box, enter the number of analog output channels used to generate waveforms.

Note: If you set the number of channels to a value greater than the number of channels configured on the DAQ 
Hardware Settings dialog, you must configure the new channel(s) before you can run the function generator. If you 
attempt to run the function generator without configuring the new channel(s), a DAQ input error dialog opens.

4. Select a channel number from the list of channels. Hold down the Ctrl key to set the options of more than one channel 
at a time.

    
    

 
  

   
 
 

   
   

   

      
    

   
         

   
      

     

    

   
 

 

   
 

     

   

  
 

  
 

   

   
 

   
 

    

Notes
n You can change values using a mouse wheel instead of the up/down arrows.
n When the option is a numeric value, you can click directly on the value to open a text box and enter a new number. 
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5. Check the Enable check box to enable the output of the selected channel on the function generator.
6. In the Name text box, enter a unique name for the channel. This option is disabled when multiple channels are 

selected.
7. Set the waveform options:

¡ Pattern type: Select the waveform type to generate for the selected channel. 
With TracerDAQ Pro the choices are Flat, Square, Pulse, Sine, Triangle, Random, Ramp, and Arbitrary. With 
TracerDAQ, the pattern type is set to Sine.

¡ Amplitude: Set the amplitude of the waveform. The amplitude range is based on the range selected for the channel 
in the DAQ Hardware Settings dialog. Amplitude is disabled when the pattern type is set to Flat.

¡ DC level: Set the DC level of the waveform.

¡ Phase: Set the phase (in degrees) of the waveform. Phase is disabled when the pattern type is set to Random or 
Flat. This option is enabled in TracerDAQ Pro only.

¡ Duty cycle: Set the duty cycle (up to 100 percent) of the waveform. Duty Cycle is disabled when the pattern type is 
set to Flat, Ramp, Random or Arbitrary. This option is enabled in TracerDAQ Pro only.

¡ Rate multiplier: Select the rate multiplier of the waveform. Choices are X1 through X10. This option is enabled in 
TracerDAQ Pro only. Rate multiplier is disabled when the pattern type is set to Random or Flat.

¡ Gate ratio: Select the gate ratio percentage of the waveform. This option is enabled in TracerDAQ Pro only.

8. Click on the Timebase tab and set either the base frequency or sweep options:

¡ Base frequency (Hz): Use the numeric up/down control to set the frequency of the signal. You can set the base 
frequency from 0.1 Hz up to the maximum output rate of the hardware divided by 100.

This option is disabled when sweep mode is enabled.

¡ Enable sweep: TracerDAQ Pro only. Check in this check box to enable sweep mode and perform linear and 
exponential frequency sweeps. 

This option is disabled when the pattern type is set to Flat or Random.

¡ Sweep mode: Select the sweep mode. Choices are:

Linear: Varies the waveform frequency linearly, from the frequency at the start of the waveform to the frequency 
at the end of the waveform.

Exponential: Varies the waveform frequency exponentially, from the frequency at the start of the waveform to the 
frequency at the end of the waveform.

¡ Sweep time (sec): Use the numeric up/down control to set the number of seconds to sweep the frequency.

¡ Start frequency (Hz): Use the numeric up/down control to set the initial frequency of the signal.
You can set the starting frequency up to the maximum output rate of the hardware divided by 100.

¡ End frequency (Hz): Use the numeric up/down control to set the final frequency of the signal. 
The minimum end frequency that you can set is 0.1 Hz.

9. Click on the OK button when you are done setting channel options.
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Setting function generator display options
You can choose the colors that appear on the function generator display. With TracerDAQ Pro, you can also disable tool 
tips from appearing on function generator dialogs.

You set these options using the Function Generator Display Settings dialog. Do the following:

1. Stop the function generator if it is running.
2. Select Display Settings from the Edit menu to open the Function Generator Display Settings dialog.
3. Check the Enable hotspot checkbox to enable hotspot controls on the function generator.
4. In the Color Scheme list box, select a color scheme from a list of predefined values.

The colors are applied to the function generator foreground (waveform preview and signal option area) and 
background.
You can also select the colors yourself using the options below. When you select the colors, the Color Scheme option is 
set to Custom.

5. Set the Contrast option to a value from 0.0 to 1.0. 

The contrast value is used to blend the foreground and background colors together to create the color applied to the 
back of the plot area.

6. Click on the Background Color button and select a color from the dialog that opens. This color is applied to the area 
of the display outside of the plot preview and waveform values.

7. Click on the Foreground Color button and select a color from the dialog that opens. This color is the applied to the 
border around the plot area, and the text outside of the plot area.

8. Click OK when you are done setting display options.

The example below shows the function generator when the Color Scheme display option is set to NavyBlue.
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Introducing the rate generator
TracerDAQ's rate generator is a virtual application used to generate analog waveforms from supported Measurement 
Computing DAQ hardware with counter outputs. The rate generator supports 9513-based counters and USB-2500 
Series/PCI-2500 Series Timer outputs. 

You select the counter channel to output. The rate generator displays the sample waveform, samples per cycle, internal 
scan rate, and base frequency of the hardware. Hotspot controls on the rate generator let you select an output channel and 
change the frequency, duty cycle, and initial state of the output signal.

With the rate generator, you can perform the following tasks:

n Generate waveforms for up to 20 counter output channels on multiple MCC DAQ devices with TracerDAQ Pro. You can 
generate a waveform for one counter output channel with TracerDAQ.

n Change the frequency, duty cycle, and initial state of the waveform on 9513-based counters 

n Change the frequency on hardware that support Timer outputs

n Save hardware configurations for future use

n Customize the appearance of the rate generator

Rate generator Quick Start
For a quick, hands-on exercise that shows you how to generate waveform signals on the rate generator, click on the Quick 
Start button below.

A Measurement Computing device with counter output channels is required to perform this quick start exercise. The rate 
generator supports 9513-based counters and USB-2500 Series/PCI-2500 Series Timer outputs. 
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Overview of the rate generator environment
When you run the rate generator application, the main Rate Generator window opens. Components on the rate generator 
are identified below. An asterisk (*) after the component name indicates that the component is also a hotspot.

n The menu bar provides access to dialogs used to perform all rate generator operations. 
Note: For more information about the menu bar, go to the Overview of the rate generator menu bar topic.

n The active state is shown at the top of the function generator ("Running" or "Stopped")

n Hotspot controls let you make changes right on the function generator without opening a dialog:

¡ Start and stop signal output

¡ Select the channel number to output

¡ Change the frequency of the waveform

¡ Change the duty cycle of the waveform (* 9513-based counters only) 

¡ Change the initial state of the waveform (* 9513-based counters only) 

¡ Enable or disable a channel

¡ Enable sweep mode (TracerDAQ Pro only)

Note: For more information about rate generator hotspots, go to the Hotspots on the rate generator topic.

n The clock speed lists the clock speed set for the hardware in InstaCal.

n The status bar shows the output status ("Running" or "Idle"), and lists configuration messages and error conditions.

n The waveform preview shows the sample waveform according to the options you select.

Error handling

If an error occurs, the rate generator stops the signal output, and displays the error message on its status bar. A dialog of 
the error message also opens. An example is shown here.
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Overview of the rate generator menu bar
The rate generator menu bar options are explained in the following table.

 

Menu item Explanation

File Includes options you can use to:
n save or load a configuration file
n configure start up preference settings
n Exit the rate generator

Click on the following button for instructions on how to perform these tasks.

Edit Includes options you can use to:
n configure your Measurement Computing hardware
n change rate generator display options
n change rate generator channel options

Click on the following button for instructions on how to perform these tasks.

View Includes an option to enable or disable pop up tool tips from appearing on function generator 
dialogs.

Action Includes options you can use to start or stop signal output

Help Includes options you can use to:
n open the TracerDAQ online help file
n view TracerDAQ version and contact information
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Hotspots on the rate generator
The Rate Generator window has several hotspots. A hotspot is an interactive area on the rate generator that lets you 
change settings while the rate generator is running. 

All hotspots have corresponding dialogs that you access through the rate generator menu bar to perform the same action.

Hotspot controls on the rate generator are identified below. 

* The DUTY CYCLEDUTY CYCLEDUTY CYCLEDUTY CYCLE and INIT STATEINIT STATEINIT STATEINIT STATE hotspots are not enabled when you are using hardware with Timer outputs. These 
hotspots are enabled when you are using hardware with 9513-based counters.  

 

Hotspot Explanation

 (Run) Starts the signal output.

 (Stop) Stops the signal output.

Channel number selector. Click the up/down arrows to select the number of 
the channel to configure.

Enables or disables channels on the rate generator. Click the EEEE  to enable or 
disable the selected channel. 

When disabled ( ), the signal preview appears as a horizontal 
line.

Click the up/down arrows to change frequency of the waveform.

Click the up/down arrows to change the duty cycle of the waveform.
Note: This hotspot is only enabled when you are using hardware with 9513-
based counters. When using hardware with Timer outputs (USB-2500 
Series/PCI-2500 Series), the duty cycle is set by default to 50%. 

Click the up/down arrows to change the initial state of the waveform.
Note: This hotspot is only enabled when you are using hardware with 9513-
based counters. You cannot change the initial state of the waveform when 
you are using hardware with Timer outputs (USB-2500 Series/PCI-2500 
Series).
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Quick Start - Generating waveforms with the rate generator 
As stated in the introduction, you can generate waveforms with TracerDAQ "soon after you install your Measurement 
ComputingDAQ hardware." You can get a feel for what TracerDAQ can do even sooner by generating a waveform with the 
rate generator.

Note: A Measurement Computing DAQ device with counter output channels is required to perform this exercise. Supported 
counter types include 9513-based counters and USB-2500 Series/PCI-2500 Series Timer outputs.

To generate a waveform with the rate generator:
1. Make sure you have completed the steps in the "Running InstaCal and adding your hardware" section of the DAQ 

Software Quick Start.
2. Run TracerDAQ by selecting Programs ���� Measurement Computing ���� TracerDAQ ���� TracerDAQ from the Start 

menu.
3. From the TracerDAQ dialog, select Rate Generator, and click on Run. The rate generator application opens.
4. Select DAQ Hardware Settings from the Edit menu. The DAQ Hardware Settings dialog opens.
5. From the first row of the DAQ Device column, select your hardware from the DAQ DeviceDAQ Device column list 

box.
The drop-down list shows the device ID and device name for all boards with counter outputs that were configured by 
InstaCal. When you select a device, the first channel and range that are supported by the device appear in the DAQ
Channel columnDAQ Channel column. 

Note: The DAQ Range/Mode column is disabled when using the rate generator.
6. Right-mouse click on the first column, and select AutoFill All from the pop-up menu. This automatically configures the 

DAQ Device and DAQ Channel for the remaining channel on the dialog.
Click here to see two counter output channels on the USB-4301 device configured for output. 

7. Click on the OK button to save the setting and close the dialog. The waveform is output to the rate generator.

8. Click the Run button ( ) to start an output scan that sends output data to all configured channels.

9. To stop the scan, click on the Stop button ( ).

That's all there is to it! The rate generator provides many options that let you change the properties of the waveform, DAQ 
hardware, and the rate generator display. Refer to the topics in the Table of Contents for more information.
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Configuring DAQ hardware for the rate generator
You can generate waveforms using Measurement Computing data acquisition hardware that support counter outputs.

You set up your hardware configuration with the DAQ Hardware Settings dialog. Use this dialog to configure the hardware 
and channels used to generate each waveform.

The first time you run the rate generator, the dialog opens without any configuration information. Dialog tool tips advise you 
of the action to take.

The rate generator must be stopped for you to configure DAQ hardware. You cannot configure hardware when the rate 
generator is running or paused.

DAQ hardware settings

To configure your DAQ hardware:

1. Stop the rate generator if it is running.
2. Select DAQ Hardware Settings from the Edit menu (or select File > New). The DAQ Hardware Settings dialog 

opens.
By default, the dialog opens with two channels to configure. To change the number of channels, right-click in the first 
column and select Number of Channels. Enter the desired number of channels in the dialog that opens, and click OK.

3. In the DAQ Device column, select a hardware device from the drop-down list. 

The drop-down list shows all boards with counter output channels that are configured by InstaCal. The list includes a 
device ID and a board name. The device ID is the board number assigned by InstaCal. For example, the device ID 
"Dev0" indicates board number 0.
When you select a device, the first counter output channel that is supported by the device appears in the DAQ Channel 
column.

Options on the DAQ Range/Mode column are disabled when using the rate generator.
4. Review the channel listed in the DAQ Channel column. If the hardware supports additional counter output channels, 

you can select a different channel number from the drop-down list. 

You can quickly configure the remaining channels to generate waveforms using the same hardware by using the context 
menu: Right-click in the first column of the first row and select AutoFill All. The hardware, channels, and range 
information populate the rows for the remaining channels.

5. Click OK when you are done configuring your hardware. 

The OK button is disabled if the dialog contains invalid entries. 

By default, the previous hardware configuration is loaded each time you open the dialog or launch the rate generator. To 
open the dialog without a hardware configuration, uncheck the Load last configuration option on the Rate Generator
Preference Settings dialog.

Context menu

You can right-click in the first column (Channeln) of the DAQ Hardware Settings dialog to display a context menu. Use the 
options on this menu to change the number of channels, configure or clear selected rows automatically, undo the last action, 
and redo the last action (when the last action was undone).

Click here for an explanation of the options on this menu.
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Saving a rate generator configuration file
You can save the rate generator hardware settings and display settings to a configuration file (*.rgc). The file is saved in 
binary format in the location specified by the Configuration file path option in the Rate Generator Preference Settings 
dialog. 

You can specify the name with which to save the configuration file, or select from a list of pre-defined names. You can load 
the configuration file to restore the hardware and display settings on the rate generator.

To save current rate generator hardware and display settings to a configuration file:

1. Select Save Configuration from the File menu. The following menu options open.

2. Click on the one of the pre-defined file names (User0 to User7) with which to save the file, or select Named 
Configuration to enter another name.
If you select one of the pre-defined (UserN) options, the configuration information is automatically saved to a file with 
that name (UserN.rgc)

If you select the Named Configuration... option, a Save As dialog opens. Enter a name for the file (and change the 
location if you want), and then click Save to save the configuration file.

You can update the configuration file with any changes you make to the hardware settings or display settings by saving the 
configuration again with the same file name.

For information on loading a saved configuration file on the rate generator, go to the Loading a rate generator configuration
file topic.
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Loading a rate generator configuration file
You can load a rate generator configuration file (*.rgc), and apply the settings to the current rate generator session.

When loaded, the hardware settings and display settings that are stored in the configuration file are applied to the rate 
generator. The name of the configuration file that you load is shown in the title bar of the rate generator.

Configuration files are stored in the location specified by the Configuration file path property in the Rate Generator
Preference Settings dialog.

To load a configuration file:

1. Select Load Configuration from the File menu. The following menu options open.

2. If the configuration file was saved using one of the predefined names (User0 to User7), you can select one of these 
from the menu.

Or, click on Named Configuration to select a configuration file from an Open dialog.

The rate generator updates with the hardware and display settings that are stored in the configuration file. The name of the 
configuration file appears in the title bar of the rate generator. An example is shown here:

For information on saving a configuration file, go to the Saving a rate generator configuration file topic.
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Setting rate generator preferences
You can set the location to store configuration files, whether to load the most recently used configuration file at start-up, and 
whether to show tool tips on rate generator dialogs.

You set start up options by selecting Preferences from the File menu to open the Rate Generator Preference Settings 
dialog (File > Preferences menu). The dialog is shown here configured with its default settings.

The preference settings are stored in the system registry in HKEY_CURRENT_USER\Software\Measurement 
Computing\TracerDAQ\Preferences\RateGenerator.

 

Menu item Description

Configuration file 
path

Sets the directory to store configuration files (*.rgc). The default path is:

n Windows 2000 and Windows XP: C:\Documents and Settings\<User 
Name>\Application Data\Measurement Computing\TracerDaq\Config

n Windows Vista: C:\ProgramData\Measurement Computing\TracerDaq\Config

Click the Browse button to select a different location.

Load last 
configuration

When checked, the rate generator opens with the hardware configuration that was 
loaded when you last closed the application.

When Load last configuration is not checked, the settings on the Rate Generator 
Preference Settings dialog are applied to the rate generator the next time you run 
the application.

Show tool tips When checked, tool tips are enabled on rate generator dialogs.

You can toggle tool tips on and off by selecting Tool Tips from the View menu.
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Setting rate generator channel options
You can configure one counter output channel on the rate generator using TracerDAQ. With TracerDAQ Pro, you can 
configure up to 20 counter output channels.

You specify the channel number, the frequency of the signal (Hz), and the options of the waveform to generate.

The frequency values are based on the available frequencies for the counter. The increment value is determined by the 
counter's base clock frequency and a divisor. The rate generator shows the actual frequency based on the output capability 
of the hardware. For example, a 9513-based counter has a base clock set in InstaCal to 5 MHz. If you change the frequency 
to 600 kHz, the rate generator shows the frequency set to 625 kHz.

With 9513-based counters you can also change the duty cycle. The value is based on the available duty cycle for the 
counter. High frequencies result in a course duty cycle increment. Low frequencies result in a fine duty cycle increment.  

A sample waveform updates on the rate generator according to the option values you set.

You can set channel options while the rate generator is stopped using the Rate Generator Channel Settings dialog. You 
can also set these channel settings while rate generator is running or stopped using hotspots on the rate generator.

Setting channel options while the rate generator is stopped (Rate Generator Channel Settings 
dialog)
1. Stop the rate generator if it is running.
2. Select Channel Settings from the Edit menu to open the Rate Generator Channel Settings dialog.
3. In the Number of channels text box, enter the number of counter output channels used to generate waveforms.

Note: If you set the number of channels to a value greater than the number of channels configured on the DAQ 
Hardware Settings dialog, you must configure the new channel(s) before you can run the rate generator. If you 
attempt to run the rate generator without configuring the new channel(s), a DAQ input error dialog opens.

4. Select a channel number from the list of channels. Hold down the Ctrl key to set the options of more than one channel 
at a time.

5. Check the Enable check box to enable or disable the channel on the rate generator. When disabled, the signal appears 
as a horizontal line in the waveform preview area.

6. In the Name text box, enter a unique name for the channel. This option is disabled when multiple channels are 
selected.

7. Set the waveform options:

¡ Initial state: Select the initial state of the waveform. Choices are High and Low. This option is enabled when you are 
using hardware with 9513-based counters. You cannot set the initial state of the waveform when you are using 
hardware with Timer Out type counters.

¡ Duty cycle: Use the numeric up/down control to set the duty cycle (up to 100 percent) of the waveform. You can 
change the duty cycle when you are using hardware with 9513-based counters. When using hardware with Timer 
outputs (USB-2500 Series/PCI-2500 Series), the duty cycle is set by default to 50% and is disabled on the rate 
generator.

¡ Frequency: Use the numeric up/down control to set the frequency of the waveform in Hz. 

8. Click on the OK button when you are done setting channel options.

Setting channel options while the rate generator is running (hotspots)

You can set channel options using the rate generator's hotspot controls without opening the Rate Generator Channel 
Settings dialog:

n EEEE : Click to enable or disable the channel on the rate generator. 

n CHANNELCHANNELCHANNELCHANNEL: Click the up and down arrows to select the channel.

n FREQUENCYFREQUENCYFREQUENCYFREQUENCY: Click the up and down arrows to set the frequency in Hz of the signal. You can also click directly on the 
value to open a text box and enter a new number.

n DUTY CYCLEDUTY CYCLEDUTY CYCLEDUTY CYCLE: Click the up and down arrows to set the duty cycle (up to 100 percent) of the waveform. You can also 
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click directly on the value to open a text box and enter a new number. * This hotspot is disabled when you are using 
hardware with Timer outputs, and enabled when you are using hardware with 9513-based counters. 

n INITINITINITINIT STATE STATE STATE STATE: Click the up and down arrows to toggle between High and Low. This hotspot is disabled when you are 
using hardware with Timer outputs. * This hotspot is disabled when you are using hardware with Timer outputs, and 
enabled when you are using hardware with 9513-based counters. 
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Setting rate generator display options
You can enable hotspots and choose the colors that appear on the rate generator with the Rate Generator Display 
Settings dialog:

1. Stop the rate generator if it is running.
2. Select Display Settings from the Edit menu to open the Rate Generator Display Settings dialog.
3. Click in the Enable hotspot checkbox to enable hotspots on the rate generator.
4. In the Color Scheme list box, select a color scheme from a list of predefined values. 

The color scheme sets the background, foreground, contrast, and channel colors to predefined values. You can 
alternately select the colors yourself using the following options. When you select the colors, the Color Scheme option is 
set to Custom.

5. Set the Contrast option to a value from 0.0 to 1.0. 
This value is used to blend the foreground and background colors together to create the color applied to the back of the 
plot area.

6. Click on the Background Color button and select a color.

This color is applied to the area of the display outside of the plot preview and waveform values.
7. Click on the Foreground Color button and select a color.

This color is the applied to the border around the plot area, and the text outside of the plot area.
8. Click OK when you are done setting display options.

The example below shows the rate generator when the Color Scheme display option is set to Rainbow.

Page 106 of 106

javascript:hhctrl.TextPopup('A hotspot is an interactive area that allows you to set various properties and actions without opening a separate dialog.','Arial,8',10,10,00000000,0xc0ffff)
javascript:kadovTextPopup(this)

	Introducing TracerDAQ
	TracerDAQ License Agreement
	Platform requirements and recommendations
	How to use this help file
	Feature comparison between TracerDAQ and TracerDAQ Pro
	Strip Chart
	Introducing the strip chart
	Overview of the strip chart environment
	Overview of the strip chart menu bar
	Hotspots on the strip chart
	Quick Start
	Quick Start - Plotting DEMO-BOARD signals with the strip chart

	Setting up the strip chart
	Configuring DAQ hardware for the strip chart
	Saving a strip chart configuration file
	Loading a strip chart configuration file
	Setting strip chart preferences

	Working with strip chart data
	Using strip chart timebase controls
	Scaling channel data on the strip chart
	Zooming in on strip chart data
	Entering or viewing annotations on the strip chart
	Saving strip chart data to a file
	Opening and plotting saved scan data on the strip chart
	Playing back scan data on the strip chart
	Plotting data from a logger file (.bin) on the strip chart
	Plotting data from a text file (.txt or .csv) on the strip chart
	Printing the strip chart image
	Capturing an image of the strip chart (TracerDAQ Pro only)
	Clearing data from the strip chart

	Setting strip chart options
	Setting the strip chart scan rate and trigger mode
	Setting strip chart trigger options (TracerDAQ Pro only)
	Setting strip chart alarm conditions (TracerDAQ Pro only)
	Showing measurements on the Strip Chart Measurements window (TracerDAQ Pro only)
	Setting strip chart lane options
	Setting strip chart display options
	Setting strip chart channel options
	Setting strip chart marker options


	Oscilloscope
	Introducing the oscilloscope
	Overview of the oscilloscope environment
	Overview of the oscilloscope menu bar
	Hotspots on the oscilloscope
	Quick Start
	Quick Start - Plotting DEMO-BOARD signals with the oscilloscope

	Setting up the oscilloscope
	Configuring DAQ hardware for the oscilloscope
	Saving an oscilloscope configuration file
	Loading an oscilloscope configuration file
	Setting oscilloscope preferences

	Working with oscilloscope data
	Using oscilloscope timebase controls
	Setting up a reference channel (TracerDAQ Pro only)
	Scaling channel data on the oscilloscope
	Saving oscilloscope data to a file
	Opening and plotting history files on the oscilloscope
	Printing the oscilloscope image
	Capturing an image of the oscilloscope (TracerDAQ Pro only)
	Clearing data from the oscilloscope

	Setting oscilloscope options
	Setting oscilloscope trigger options
	Setting oscilloscope marker options
	Setting oscilloscope display options
	Setting oscilloscope channel options
	Setting oscilloscope math channel options (TracerDAQ Pro only)
	Showing measurements on the Oscilloscope Measurements window (TracerDAQ Pro only)


	Function Generator
	Introducing the function generator
	Overview of the function generator environment
	Overview of the function generator menu bar
	Hotspots on the function generator
	Quick Start
	Quick Start - Generating a waveform with the function generator

	Setting up the function generator
	Configuring DAQ hardware for the function generator
	Saving a function generator configuration file
	Loading a function generator configuration file
	Importing arbitrary data files for output on the function generator
	Setting function generator preferences

	Setting function generator options
	Setting function generator channel options
	Setting function generator display options


	Rate Generator
	Introducing the rate generator
	Overview of the rate generator environment
	Overview of the rate generator menu bar
	Hotspots on the rate generator
	Quick Start
	Quick Start - Generating waveforms with the rate generator

	Setting up the rate generator
	Configuring DAQ hardware for the rate generator
	Saving a rate generator configuration file
	Loading a rate generator configuration file
	Setting rate generator preferences

	Setting rate generator options
	Setting rate generator channel options
	Setting rate generator display options



